IBM Support

ICN rows do not scroll as expected when using the mouse wheel

Troubleshooting


Problem

IBM Content Navigator (ICN) rows in Search and Browse views do not scroll as expected when using the mouse wheel.

Symptom

This issue occurs when working in an ICN desktop, in the 'Search' or 'Browse' views.
After scrolling down to the bottom of the list of documents and then starting to scroll up using a mouse wheel or equivalent, the scroll bar on the right moves up as expected, however the rows do not move up and instead appear to 'twitch' while the selected document remains the same.

See attached demo for example:

Scroll Jumping.wmvScroll Jumping.wmv

Cause

This is caused by a new switch introduced by Google Chrome v56:
chrome://flags/#enable-scroll-anchoring

Environment

ICN v 2.0.3.8 and ICN v3.0
Client OS: Windows 7/8/10
Google Chrome version 57.0.2987.110 (32 bit)

Diagnosing The Problem

This issue occurs only on Chrome browser (v56 or later).
The issue is not reproducible with Internet Explorer or Firefox.

Resolving The Problem

Once the mouse wheel is released, or the view is scrolled to the top the issue resolves itself.
To resolve the issue permanently for each user, the Chrome flag
chrome://flags/#enable-scroll-anchoring
can be set to disabled.

Note that Chrome flags cannot be set programmatically, so this will need to be performed manually by the user.

[{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ICN and CM FileNet","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"2.0.3.8;3.0.0","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}}]

Document Information

Modified date:
17 June 2018

UID

swg22002954