Troubleshooting
Problem
Your IBM WebSphere application server is failing to start with a "java.io.IOException: There is not enough space in the file system." in the nativestderr.log file.
Cause
The IBM i QEJBSVR user profile has reached its maximum allowed storage limit. The "Maximum Storage Allowed" property is likely not set to *NOMAX for the user profile.
Environment
IBM WebSphere Application Server; IBM i OS
Diagnosing The Problem
Look at the application server's nativestderr.log for the following exception:
java.io.IOException: There is not enough space in the file system.
The log file is located in: /qibm/userdata/websphere/appserver/<version>/<edition>/profiles/<profileName>/logs/<serverName>
Resolving The Problem
Display the user profile the application server is running under (QEJBSVR by default) and check the value for 'Maximum storage allowed'.
DSPUSRPRF QEJBSVR
If it is set to anything other than *NOMAX, then this is most likely the cause of the problem. Having a specific amount for this value will limit the amount of storage the WebSphere Application Server profile can use and could result in application server startup issues. It is recommended the QEJBSVR user profile have a "Maximum storage allowed" set to *NOMAX to avoid any issues.
CHGUSRPRF USRPRF(QEJBSVR) MAXSTGLRG(*NOMAX) MAXSTG(*SAME)
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Document Information
Modified date:
18 December 2019
UID
nas8N1021651