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In IBM Sterling Call Center, 'OMS server is unable to process requests' error appears while creating orders

Troubleshooting


Problem

In IBM Sterling Call Center (Next-generation), try to create an order. It is throwing an error 'OMS server is unable to process requests. Contact your tenant administrator.'

Symptom

Steps to reproduce:

1. Login to Call Center

2. From Home page, Create Order and select enterprise and click Ok

3. In Customer details page, select any existing customer and click Next

4. In Add product page, under Categories select any category. The items are displayed.

5.  For any item, click 'Add to cart' button

Result: Error 'OMS server is unable to process requests. Contact your tenant administrator.' appears.

Cause

This error appears when correct resource permissions are not there for CSR user group.

Environment

 IBM Sterling Call Center (SaaS) (Next-generation)

Diagnosing The Problem

Some HAR log statements:

POST https://<hostname>/icc/ICCMashupServlet

Giving - 400 Bad Request

{

"mashupResponse": {

"Error": {}

}

}

Post data :

{"MashupRefs":{"MashupRef":[{"mashupId":"icc.order.create-order.addToCart","Input":{"Order":{"EnterpriseCode":"Emart","OrderHeaderKey":"20230626092852212033259","OrderLines":{"OrderLine":{"OrderLineKey":"","DeliveryMethod":"SHP","OrderedQty":1,"Item":{"ItemID":"Item1","UnitOfMeasure":"EACH"},"LinePriceInfo":{"ListPrice":"148.00","UnitPrice":"148.00"},"OrderLineTranQuantity":{"OrderedQty":1},"OrderOverride":{"QuantityLimitOverridden":"N"}}},"DocumentType":"0001","DisplayLocalizedFieldInLocale":"en_US_EST"}}}],"isMultiAPICall":false}}

Some WUFAll log statements:

For (mashup :: icc.order.create-order.addToCart) the (authorization_failed) 
Mashup invocation failed. Reason: Mashup could not be authorized. Mashup ID - icc.order.create-order.addToCart

Resolving The Problem

(1) The Call Center (Next generation), uses the permissions set for CSR-Group or CSR-Lead-Grp. Open up the resource permissions settings for CSR-Group or CSR-Lead-Grp and ensure that the (ICC_ORDER > ICC_Create_Order) and (ICC_PRODUCT > ICC_Product_Browsing) are enabled with checkmark.

(2) Restart the application server to see if it clear things up and reloads the proper permissions.

If these permission groups are unavailable, then CDT can be performed from MC or get help from DevOps team to run factory Setup.

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB77","label":"Automation Platform"},"Business Unit":{"code":"BU048","label":"IBM Software"},"Product":{"code":"SS6PEW","label":"IBM Sterling Order Management"},"ARM Category":[{"code":"a8m0z000000cxzVAAQ","label":"Call Center Store and SIM"}],"ARM Case Number":"TS013425073","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]

Document Information

Modified date:
19 May 2025

UID

ibm17022447