IBM Support

IBM Sterling Call Center - Error while enabling the customization in Windows Subsystem for Linux environment

Troubleshooting


Problem

In IBM Sterling Call Center on Windows Subsystem for Linux (WSL), enable the customization. 
Open the related overrides.json file, set runAsCustomization to true for 'order-search' and 'order-details' pages. Open order search page for an order and start the yarn. 
Below error appears in the yarn log-

order-search: Killed
error Command failed with exit code 137.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
lerna ERR! yarn run start-merged --host=localhost -port=5102 —-live-reload=false —ssl exited 137 in 'order-search' order-details: Browser application bundle generation complete.

If customization is enabled only for the 'order-search' then it is working fine, but if it is enabled for both 'order-search' and 'order-details' then it fails with above error.

Symptom

  • A pop-up appears at top with an error 'Failed to load module order-search'. 
  • In yarn log below error appears-
order-search: Killed
error Command failed with exit code 137.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.
lerna ERR! yarn run start-merged --host=localhost -port=5102 —-live-reload=false —ssl exited 137 in 'order-search' order-details: Browser application bundle generation complete.

Cause

Yarn error code 137 occurs when the WSL runs out of memory and the Linux kernel kills processes to free up memory.

Environment

IBM Sterling Call Center (next-generation) on WSL.

Diagnosing The Problem

Use command 'free -mh' to check the available memory. Increase memory if it's not enough.

Resolving The Problem

By default WSL uses around 50% of total memory on Windows. Herein, Windows had 16 GB of memory, so by default around 8 GB of memory was allocated to WSL. Developer toolkit was also installed on WSL which had also consumed some memory.

Steps to resolve:

1. Open Windows Start menu, type Windows PowerShell. 
    Right click on Windows PowerShell, and then select 'Run as administrator'.
2. Run command: wsl.
3. Run command & check output: free -mh.
    On checking memory usage, it was found that very less memory (for example 530 MB) was free out of total memory (for example 7.6 GB).

4. Run "notepad.exe %UserProfile%/.wslconfig" in the windows explorer address bar.
    By default, it creates this file at path: C:\Users\<User Name>.
    P.S. <User Name> is a placeholder for actual user.
5. Paste sample text below as the content for this file. This is done to increase memory to 10 GB. 
[wsl2]
#Limits VM memory to use no more than 4 GB, this can be set as whole numbers using GB or MB
memory=10GB
6. Save file & close it. Make sure file is renamed from '.wslconfig.txt' to '.wslconfig'.
7. To stop the wsl service, run command: wsl --shutdown.
P.S. Here, Docker Compose services were stopped as well using 'om-compose.sh stop' command.
8. To start the wsl service, run command: wsl
P.S. Here, Docker Compose services were started as well using 'om-compose.sh start' command.
9. Run command & check output: free -mh.
Memory will be increased to around 10 GB.

10. Login to Call Center & test the customizations.
Customization for 'order-search' and 'order-details' works without any error.

Document Location

Worldwide


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Document Information

More support for:
IBM Call Center for Commerce

Component:
Call Center Store and SIM

Software version:
All Versions

Document number:
7154959

Modified date:
13 June 2024

UID

ibm17154959

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