IBM Support

IBM Security Guardium - Emails are not being sent with authenticated user for SMTP

Troubleshooting


Problem

IBM Guardium can’t send emails with authentication type set as AUTH.
vmguard7> show alerter smtp authentication type
AUTH
ok

Symptom

The below messages are generated in the syslog (message) file
Jan 17 16:02:22 xx-xx sqlguard_sender: Authentication error.
Jan 17 16:02:22 xx-xx sqlguard_sender: VMime exception in SMTP Send

The messages file can be seen by using the fileserver.

Cause

When attempting to send an email, your email program can report an "Authentication Failed" error message. One of the causes is when AUTH is not in the response from SMTP server, but it is set on IBM Security Guardium™ side. 
 

Diagnosing The Problem

Check with your SMTP administrator whether AUTH is used at SMTP server-side for this client. You will also need to find out whether you need AUTHENTICATION in alerter configuration or not.

Resolving The Problem

If SMTP server side does not need AUTH from the client, remove the User and Password from Alerter.

1.Setup > Tools and Views > Alerter

image 3806

2. Change the authentication type from CLI to NONE

  store alerter smtp authentication type NONE  restart alerter

If you want the alerter configuration to use AUTH and are still getting an error, kindly open a case with IBM Support attaching following diagnostics information: 

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"ARM Category":[],"Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
28 May 2020

UID

ibm16210268