IBM Support

The IBM Rational Team Concert (RTC) Eclipse client is unable to login automatically

Troubleshooting


Problem

You have created a new Repository connection or using an existing one and you have selected the options "save password" and "automatically log in" but you receive the message: "The password cannot be empty" and you have to re-enter your password every time you launch the client.

Symptom

You have created a new Repository connection or using an existing one and you have selected the options "save password" and "automatically log in".

Expected result:
You log in automatically in the repository when you start the Eclipse RTC client.

Actual result:
You get the message: "The password cannot be empty" and you have to re-enter your password every time you launch the client.

Cause

This is caused by a Eclipse secure storage issue.

Resolving The Problem

Please delete the Eclipse Secure storage as indicated below:

The Secure Storage preference page can be found under command link General -> Security -> Secure Storage.

The secure storage can be deleted using the "Delete" button on the Secure Storage preference page.

This, of course, will delete all the contents of the secure storage.

It is highly recommended that you restart the application after secure storage has been deleted.

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Product Synonym

Rational Team Concert

Document Information

Modified date:
17 June 2018

UID

swg21968225