IBM Support

IBM Rational DOORS Web Access hangs during login

Troubleshooting


Problem

This tech note explains how to recover when your browser hangs while trying to log into IBM Rational DOORS Web Access.

Symptom

You can access the IBM Rational DOORS Web Access login screen fine, but after entering valid credentials, the browser hangs, and the login process never finishes.

Cause

There is a communication problem between the IBM Rational DOORS Web Access (DWA) processes that prevents DWA from functioning correctly. Most commonly, the communication problem is between the Interoperation Server and Broker processes.

Environment

This problem is most commonly seen on systems where the IBM Rational DOORS Web Access Interoperation Server has crashed or hung.

Diagnosing The Problem

When the browser hangs, do not end the session -- let the browser hang for at least 10 minutes. After 600 seconds, it will time out, and you will see an error message in the browser with an exception. Search your IBM Rational DOORS Web Access (DWA) log files -- or the command windows where you started DWA -- and you will find an error like:


ERROR com.telelogic.festival.generalservices.authentication.DWAAuthenticationProvider  - [Message:Failure during authentication: Unexpected exception : Caused by: java.util.concurrent.ExecutionException: Unexpected exception : Caused by: Timeout occurred whilst waiting for  the message to be consumed after <600> (s).

If you cannot find any errors in your DWA log files, and there are no command windows showing DWA messages -- perhaps because you start DWA via a script, custom service, or scheduled task -- you will need to manually stop DWA, and then manually restart it. After the manual restart, search the resulting windows for errors. If you find none, attempt to log in. If the browser hangs, let the session time out, then search for the error in the command windows.

Resolving The Problem

To resolve this issue, stop Rational DOORS Web Access (DWA) and verify that all DWA processes were terminated. If rogue DWA-related processes remain, kill them manually. Once DWA is fully terminated, restart DWA as documented in the DWA installation guide. The problem should be resolved after DWA has finished starting cleanly and successfully.

If you normally use a script, custom service, or scheduled task to start DWA, and your last DWA start attempt was manual, manually stop DWA and restart it via your script, custom service, or scheduled task. Then verify that you can still log into DWA successfully.

NOTE:

This tech note describes how to recover from a single instance of DWA hanging. If DWA hangs repeatedly in your environment, you will need to use the errors and other information discovered while troubleshooting this issue as described above to determine what is causing DWA to repeatedly hang.

Examples of things that could interfere with DWA:

  • SE Linux is running on the Linux server where DWA is installed, and it is not configured to let DWA run correctly. If you have SE Linux running, you need to configure it to allow DWA to run -- see the SE Linux logs for more details on the settings that need to be changed. To temporarily allow DWA to run while you reconfigure SE Linux, you can have SE Linux run in Permissive mode.

  • It is possible for some security or anti-virus software that is supposed to be configurable to not interfere with specific components to still interfere with those components. For example, we have seen cases of Norton and Blink being configured to not interfere with DWA, but still interfering. It is possible that the interfering security software may be monitoring the whole network/site instead of being on the actual Linux system.

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Document Information

Modified date:
01 May 2020

UID

swg21423526