IBM Support

IBM Navigator for i Login Failed Error Message

Troubleshooting


Problem

User logs in to the IBM Navigator for i Sign on screen and gets error message: "Login failed. Check the user ID and password and try again. java.lang.StringIndexOutofBoundsException"

Cause

The user has used an invalid character at the end of her password.

Diagnosing The Problem

User logs in to the IBM Navigator for i Sign on screen and gets error message:
"Login failed. Check the user ID and password and try again. java.lang.StringIndexOutofBoundsException"

Resolving The Problem

Check with the user to see if they use any special characters in their password. In this case user had "/" at the end of her password. Changing it to "!" resolved the issue.

[{"Product":{"code":"SWG60","label":"IBM i"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Basic System Environment Functions (BSEF)","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]

Document Information

Modified date:
18 December 2019

UID

nas8N1022529