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IBM Maximo MRO Inventory Optimization - Why am I getting HTTP 429 - Too many Requests error while running Extract API

Question & Answer


Question

I am trying to run the Extract API to extract the last month's data and the data is extracted. However, after trying to run the same API multiple times, it shows - HTTP 429 - Too Many Requests.

Cause

This error occurs if multiple extract requests are made simultaneously. Only one extract request can be in progress at a time.

Reference: https://www.ibm.com/docs/en/mio?topic=api-extract#concept_bb2_4mz_kdc__title__8


Answer

This error occurs if multiple extract requests are made simultaneously. Only one extract request can be in progress at a time.  Typically, The API may provide a Retry-After header in the 429 error response. This header tells the client how long to wait before making another request. If the Retry-After header is present, customer should follow the duration indicated. Example of the Retry-After header: Retry-After: 120

Item history and snapshot extracts can take a very long time as a potentially huge amount of data can be returned.  In this case the user running the Extract API needs to wait for longer time for example hours together to run the same API for a different tenure.


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Product Synonym

MRO
MAXIMO MRO

Document Information

More support for:
IBM Maximo MRO Inventory Optimization

Component:
MRO/IO->Question/Answer

Software version:
All Versions

Document number:
7185465

Modified date:
12 March 2025

UID

ibm17185465

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