IBM Support

IBM Kenexa BrassRing on Cloud: eLink Errors

Troubleshooting


Problem

User receives the error message “You are not authorized to take this action” or “You don’t have privileges for editing this form” when trying to open an eLink.

Resolving The Problem

ISSUE:
User receives the error message “You are not authorized to take this action” or “You don’t have privileges for editing this form” when trying to open an eLink.



CAUSE:
The user does not have the correct user type privilege(s) to view/edit whatever has been eLinked to them for their action -OR- the form does not have the appropriate privileges set on the form attributes page.

RESOLUTION:
Edit the form-level privilege(s) (on the form attributes page) OR grant the user type the ability to view/edit the functionality in question. The user must have the appropriate privilege to view/edit/approve via the eLink functionality.

Example #1: A user gets the error message “You are not authorized to take this action” when they attempt to open the link to view/edit a req that was eLinked to them. In this case, the user’s user type did not have access to view/edit reqs that they did not have a ‘my req’ relationship to. (The user’s user type had access to view ‘My Reqs’ but not ‘All Reqs’.) To resolve, the user must be added to the req team to be granted the ‘my req’ relationship OR the user type must be updated to allow all users to view all reqs, regardless of the ‘my req’ relationship. The final resolution will depend on your organizations recruitment process and policies.
Path to Resolve (allowing all users to view/edit all reqs): Workbench > Tools > Users > User types > Edit type permissions for the user type in question > Reqs.
Path to Resolve (adding this user to the req team): BrassRing > Search for the req in question > Edit > Add the user to the req team field > Save.

Example #2: A candidate gets the error message “You don’t have privileges for editing this form” when they attempt to open the link to complete/view/edit the Application form (candidate form) that was sent to them. In this case, the QuickStart user type (what candidates are considered) does not have access to add/edit/view the specific form that was sent to them. To resolve, the form attributes must be edited to allow the QuickStart user type to be able to add/edit/view the form.
Path to Resolve (allowing the QuickStart user type to add/edit/view the form): Workbench > Tools > Forms > Candidate Forms > Edit form attributes for the form in question > Select the QuickStart user type in the “Add/View/Modify My” > Save.

[{"Product":{"code":"SSEUFV","label":"IBM Kenexa BrassRing on Cloud"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB27","label":"Talent Management Solutions"}}]

Document Information

Modified date:
25 June 2018

UID

swg21999592