Question & Answer
Question
IBM Java for AIX HowTo: Install the FIRST or LATEST Release of an IBM Java Version
Answer
The instructions in this document make references to generic terms in Italics that will need to be replaced with information specific to the support call and the environment. It is very important that consistent and accurate values be used in place of the Italicized generic terms when collecting the data to ensure the prompt and correct delivery of the data when uploaded.
Download
A. Download the desired JRE and/or SDK filesets for the FIRST or LATEST release for the desired version(s) from the "IBM Java for AIX Service Information and Download Guide" web page:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1022644
B. Create a temporary directory, then save a copy of the downloaded files into that directory:
# mkdir -p /TMP_PATH/java_install
{Save a copy of the downloaded files to /TMP_PATH/java_install directory}
C. Extract the contents of the download files in the temporary directory. In a command prompt, execute the commands:
# cd /TMP_PATH/java_install
# ls Java*.tar.gz
{For each file listed from the last command, execute the commands}
# gunzip -c < TAR_GZ_FILE | tar -xvf -
{Confirm the *.jre and/or *.sdk files have been extracted}
# ls Java*.sdk Java*.jre
B. Examples of commands to be executed:
# mkdir -p /tmp/java_install
# ls *.tar.gz
Java7.jre.tar.gz
Java7.sdk.tar.gz
C. Examples of commands to be executed:
# cd /tmp/java_install
# ls Java*.tar.gz
Java7.jre.tar.gz
Java7.sdk.tar.gz
# gunzip -c < Java7.jre.tar.gz | tar -xvf -
# gunzip -c < Java7.sdk.tar.gz | tar -xvf -
# ls Java*.sdk Java*.jre
Java7.sdk
Java7.jre
Install
A. Command line installation
1. From a command prompt, and while logged in as the root user, execute the commands:
#cd /TMP_PATH/java_install
# installp -agXYd . JavaX.jre JavaX.sdk 2>&1 | tee installp.log
or
# installp -agXYd . JavaX_64.jre JavaX_64.sdk 2>&1 | tee installp.log
B. SMIT (or smitty) installation
1. From a command prompt, and while logged in as the root user, execute the commands:
# cd /TMP_PATH/java_install
# smittty install_all
2. Follow these instructions while using the SMIT utility
a. Menu #1 (Install and Update from ALL Available Software)
Option::* INPUT device / directory for software
Input: Type "./" in the field
{Press the ENTER key to proceed to next menu}
b. Menu #2 (Install and Update from ALL Available Software)
Option: * SOFTWARE to install
Input: Press the F4 key (or ESC+4 keys) to view the list of installed software. Then scroll to the desired filesets and select the filesets by pressing the the F7 key (or ESC+7 keys) for each filesets. Press the ENTER key once all of the filesets have been selected.
Option: ACCEPT new license agreements?
Input: Press the TAB key to change the value from "no" to "yes"
{Press the ENTER twice to begin the installation}
{Press the F10 key (or ESC+0 keys) to exit the SMIT utility}
A. Examples of commands to be executed:
# cd /tmp/java_install
# installp -agXYD . Java7.jre Java7.sdk 2>&1 | tee installp.log
B. Examples of commands to be executed:
# cd /tmp/java_install
# smitty install_all
Confirm
Confirm that IBM Java for AIX has been installed using the following methods.
A. From a command prompt, execute the command:
# lslpp -l "Java*"
In the output listed, the JavaX and/or JavaX_64 versions selected during the installation should be listed as COMMITTED.
B. From a command prompt, execute the command:
# /usr/javaX/jre/bin/java -version
and/or
# /usr/javaX_64/jre/bin/java -version
# lslpp -l "Java*" | grep Java7
Fileset Level State Description
----------------------------------------------------------------------------
Path: /usr/lib/objrepos
Java7_64.sdk 7.0.0.210 COMMITTED Java SDK 64-bit Development Kit
B. Examples of commands to execute:
# /usr/java7/jre/bin/java -version
java version "1.7.0"
Java(TM) SE Runtime Environment (build pap3270sr9fp1-20150602_01(SR9 FP1))
IBM J9 VM (build 2.6, JRE 1.7.0 AIX ppc32-64 Compressed References 20150406_242981 (JIT enabled, AOT enabled)
J9VM - R26_Java726_SR9_20150406_1443_B242981
JIT - tr.r11_20150401_88894
GC - R26_Java726_SR9_20150406_1443_B242981_CMPRSS
J9CL - 20150406_242981)
JCL - 20150601_01 based on Oracle 7u79-b14
Step 4:
Troubleshoot
A. If the install of IBM Java for AIX failed and the issue could not be resolved, it is recommended that the following data be collected and uploaded to a new IBM support call which has been routed to the "AIX Install" team or "AIX Java" team.
1. Collect and package the SMIT log files or installp log file by executing the following commands from a command prompt using the user id used in Step 2. Install:
# mkdir -p /TMP_PATH/MM-DD/java_install/data
# cd /TMP_PATH/MM-DD/java_install/data
# cp ${HOME}/smit.* /TMP_PATH/java_install/installp.log ./
# cd /TMP_PATH/MM-DD/java_uninstall
# tar -cf - data | gzip -c > PMR.MM-DD.tgz
2. Upload the packaged data using one of the IBM secure upload methods listed on the "IBM Java for AIX MustGather: How to upload diagnostic data and testcases to IBM" web page:
http://www-01.ibm.com/support/docview.wss?uid=isg3T1022619
ACTION
ACTION
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
isg3T1022692