Troubleshooting
Problem
User experiencing the following message in the product logs:
CDCz joblog shows message: +CHC9210E (
Symptom
Change data capture begins a mirroring continuous of a subscription. User experiences a DB2 CAF error. In the CDCz jeslog we see that we begin scraping the position in the log which is older compared to the position in the log where the <SUBSCR> started scraping.
CHC0046I Scraping begins with data written at 2011-03-19-17.13.58.970432 (Log Position
X'C77ED7ECEE440001').
CHC0289I Cache is starting with a range of X'C70EE688ABE50000' through X'C711644EDD140002'
Message CHC9209I DB2 Log is unavailable; retrying is generated for 8 retry's then
CHC9210E DB2 CAF IFI-READS request has failed. ReturnCode=X'00000008', ReasonCode=X'00E60863', Diagnostic information (X'C711644EDD140002')
The DLR CHC9209I message indicates a problem with the DB2 Log Cache.
Cause
IBM InfoSphere Change Data Capture for DB2z started task should be shutdown using the command
F <CDCZtask>,shutdown This will cleanly shut down CDCz and all its tasks.
.
Environment
IBM InfoSphere Change data capture running on z/OS for DB2
Diagnosing The Problem
Review CDCz Jeslog for the CHC9209I messages. Verify the starting range for the subscription from message CHC0046I.
Resolving The Problem
Clean up the DB2 log Cache.
In the CDCz started task we added the following:
// '/COMM,DBMS,CONFIG=00,COLDSTART=DLR'),
.
Restarted CDCz, Ensure that you removed the COLDSTART statement from the JCL before the next restart of the CDCz started task. .
Without a cold start, the DLR task leaves the
existing DB2 Log Cache intact and continues to cache DB2
Log records from the point in the DB2 log where it left off in
the previous InfoSphere CDC address space invocation
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21474209