Troubleshooting
Problem
In IBM i2 Analyst's Notebook, when trying to add a link between two IBM i2 iBase entities (with iBase connected) the box where you fill in for information about the link does not appear on the screen. It looks like the dialog box is outside the boundaries of the screen, and the program just beeps if you try to enter anything.
Cause
Registry key is incorrect.
Resolving The Problem
- Close all the i2 products
- Open the Regedit software (if you don't have Admin rights on your computer, you might need for the assistance of your IT dept.

- Go to the following key :
HKEY_CURRENT_USER\Software\i2\iBase\8\DialogSettings

- Rename the folder DialogSettings to DialogSettings_OLD (or something similar)

- Restart i2 Analyst's Notebook and i2 iBase.
- Check if everything is OK.
This solution (renaming the Registry key) is quite effective for all the problems that share the same behaviour :
- Happens for only one or 2 users
- If another user connects to the same computer, problem does not occur
- If initial user connects on another PC, problem does not occur.
This is a good hint on the fact that the problem is linked to the HKEY-CURRENT_USER registry key.
So, renaming the key is quite effective in solving the problems.
Sometimes, you may have to rename the key at an upper "level" in the Registry hierarchy.
You can go up to renaming the key i2 (in HKEY_CURRENT_USER\Software) to i2_OLD.
The point of renaming the key instead of deleting it is that if nothing works after the change, you can still revert to the original values.
But if it works, you can keep it for a couple of weeks, and then delete the XXX_OLD key.
[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.11;8.9.5;8.9.7;8.9.9","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21976706