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IBM i2 iBase - how to fix the error message "unrecognized database format" when opening the iBase database

Troubleshooting


Problem

The iBase database (the *.idb file) is in MS Access format. The user attempted to open the iBase database. However, the database cannot be opened, and iBase displays the error message: "Unrecognized database format...."
error message

Cause

This error is a result of a corrupted Access database. As MS Access is used, sometimes it can become corrupted.

An Access database file can become corrupted in particular circumstances. For example, there is a small risk of database corruption if a database file is shared over a network and multiple users work directly with the file simultaneously. The Access database is also at risk of corruption if users frequently edit data in Memo fields, and the risk grows over time. Usually the corruption risk can be  mitigated by Compacting and repairing the database.

In most cases, the Access database corruption is caused by a problem with a Visual Basic for Applications (VBA) module, and usually it does not pose a risk of data loss. However, this type of corruption does pose a risk of database design damage, such as lost VBA code or unusable forms.

Rarely, database file corruption does result in data loss. The file can often be repaired, but some data may be missing after the repair is complete.

Resolving The Problem

There are three ways to resolve this problem.
Method A - Restore the backup of iBase database.
The easiest way to resolve this problem is to restore the back up of the iBase database (the *.idb file). IBM i2 support strongly recommend our customers to make back ups of the database files on regular basis. Restoring a backup database is the most efficient way to minimize the downtime in the production environment when the database becomes corrupted. However, if the back up database is not available, then please move on to method B.
Method B - using the database repair feature in iBase Designer, to repair the database.
You can use iBase Designer to try and repair the database. The steps are
Step 1 - Launch iBase Designer, and log on to the security database (*.ids) with the database administrator account
Step 2 - Go to "Tools" -> "Database Administration" -> "Repair and compact" -> "Database file"
designer
Step 3 - Select the corrupted *.idb file and then run the repair
Step 4 - After the repair operation is completed, verify that the *.idb file can now be opened.
If Method B still cannot fix the corrupted database and the problem persists, then continue to Method C
Method C - Use MS Access to repair the database file
If you tried to repair the database in iBase Designer to no avail, then you can also use MS Access to repair the database file. If you use MS Access to repair the database, then i2 support cannot guarantee the data in the database, but this method has proven to be successful in limited testings.
Follow these steps to run the repair in MS Access
Step 1 - Make a back up of the corrupted idb
Step 2 - Launch iBase Designer, and log on to the security file with the database administrator

Step 3 - Create a new database file (a new *.idb), in MS Access format, while logged on to the security file.

Step 4 - Go to "Tools" - > "Feature Availability" -> "Options" -> "Advanced".  At the bottom you will see the database password.
feature

pw

Step 5 - Copy the database password to a temporary location for later use

Step 6 - Close the new database (you can delete it later if you want). Then launch MS Access application

Step 7 - Go to File menu and browse to the directory where the corrupted idb file is, then highlight that idb file and open

Step 8 - Enter the database password copied in step 5, and click ok

Step 9 - A message might appear, it can be similar to "Microsoft Access did not shut properly would you like Access to attempt to repair the file?"

Step 10 - Choose Yes, and Access should then repair open the file

Step 11 - Close Access and save the file if prompted

Step 12 - Login to iBase Designer again using the same security file as before, and then opened the idb and verify it is working properly. But also perform the test in iBase user. The database file should be repaired at this point and so you will not receive the error message anymore.

Document Location

Worldwide

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Document Information

Modified date:
16 October 2020

UID

ibm16349062