Troubleshooting
Problem
Icons and text in IBM i2 iBase may appear corrupted or impossible to read when using a display with a large resolution or high DPI setting.
Symptom
Text in i2 iBase may appear very small and icons may appear to be black or corrupted as in the screen shots below.



Cause
If your installation of i2 iBase is on a machine connected to a very high resolution/high DPI display (typically something greater than 1920 x 1080, for example 3200 x 2400), in order to make items easier to read on the display, Microsoft Windows may use display scaling to increase the size of certain UI elements and text.
In older applications however, this can have detrimental effects.
In older applications however, this can have detrimental effects.
Resolving The Problem
- To resolve the issue, navigate to the location where i2 iBase is installed (typically something like C:\Program Files (x86)\i2 iBase 8), right click the i2 iBase executable (iBase.exe) and click Properties.

- This will then display the application properties window for i2 iBase. On this window, select the 'Compatibility' tab, and then from the options click the 'Disable display scaling on high DPI settings' check box in the Settings section then click 'OK'.

- When you next launch the application, the text and UI should not be scaled and should render as expected.
The steps above can also be used to apply the same resolution to the iBaseDesigner application.
Note that in later versions of Windows 10, these settings may look different.

Use the 'Change high DPI settings' button and you will be presented with the following screen.

In this window, select the checkbox for 'Override high DPI scaling behavior' and set the 'Scaling performed by:' setting to either 'System' or 'System Enhanced'.
[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.5;8.9.1;8.9;8.9.11","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
Was this topic helpful?
Document Information
Modified date:
10 June 2021
UID
swg21992811