Troubleshooting
Problem
On the IBM i2 iBase user interface (either the iBase User or Designer), some or most of the small icons for the features are not showing up, and white circles are displayed instead.
Symptom
On IBM i2 iBase, the user interface looks like this :

instead of the normal display.
Cause
iBase is using a folder that holds all the small icons for the functions. The location of this folder is defined in the Tools - Options parameters of iBase.
In case the location of this folder is incorrect, or the folder doesn't contain the correct icon files, then iBase (User or Designer) will display white circles instead.
Resolving The Problem
- Launch IBM i2 iBase User
- Go to the Tools menu, then Options
- On the popup window that is displayed, go to the Advanced tab
- At the bottom of the Advanced tab, you have the "Graphics Folder:" field
- Check the value of this field. By default, the value should be:
- for iBase 8.x: C:\Program Files (x86)\i2 iBase 8\Graphics
- for iBase 9.x: C:\Program Files (x86)\i2 iBase 9\Graphics
- If your value is not the default value, this maybe an error (for example because you changed the folder previously). You can change the value back to default.
- If the value is indeed the correct default one, then open a Windows Explorer and go to this folder. Check that the folder contains all the *.ico files. You should have about 117 files:

- (note: this is only a portion of the folder)
- If the icon files are missing, then copy them from another iBase install, or you can also make a Repair install of iBase. This will bring back the missing icon files.
- Once the changes have been done, restart iBase and check that the small icons are now showing up in the iBase user interface.
If it's still not working, please contact the IBM i2 Support Team through the IBM Support page, and we'll help you fix the problem.
Document Location
Worldwide
[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"ARM Category":[{"code":"a8m50000000Caw4AAC","label":"i2 iBase and i2 Analyst's WorkStation->General"}],"ARM Case Number":"TS006036829","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions"}]
Was this topic helpful?
Document Information
Modified date:
01 July 2021
UID
ibm16468921