IBM Support

IBM i2 iBase Database fails to Upsize to Microsoft SQL Server

Troubleshooting


Problem

When attempting to upsize a Microsoft Access based IBM i2 iBase database to Microsoft SQL Server, the upsize fails with an error.

Symptom

When the Database Upsize Wizard fails, the following error is displayed.

IBM i2 iBase 8
Operation is not allowed in this context.

Details >>
Error# 3219 occurred in:
ADODB.Recordset
CDBUpsize:mUpsizeDB
CDBUpsize:UpsizeDB
idDBEngine:UpsizeDatabase
FDBUpsize:mUpsize
FDBUpsize:wznNavigation_StepProcess

Cause

Corrupt or incompatible data within the i2 iBase database

Resolving The Problem

The issue is caused by finding data which is either corrupt, or incompatible with SQL Server. To resolve the issue you must first isolate then remove the data, before attempting the upsize again.

  1. When the error occurs, make a note of the point at which the Database Upsize Wizard failed. As the upsize progresses, the window is updated to tell you what the current Operation is. If one of these operations fails, it will report this in the column labelled 'Status'. For example, if the table 'Nominal_' were to fail, the Status column would say 'Failed'.
  2. Close iBase user and designer.
  3. Select the .idb file for your failing database in Windows, and choose to open it with a different application instead. Choose to open the database using Microsoft Access.
  4. When the database opens, expand the table which is where the upsize failed in step 1.
  5. Sort the view of the data which is in the table into a sensible order. (We suggest checking date fields first, as this is the most common cause of the problem.)
  6. Then check the top result and the bottom result of the data in the table. More often than not, due to the fact you have sorted your data, corrupt or incompatible data will appear at these locations and be easier to find. (If corrupt data does not appear at the top or bottom of the list, you will need to manually search the fields to find the error causing data). (An example of corrupt data could be ####### ### ###, or a date occurring before 1/1/1753, which SQL Server does not handle).
  7. When you have found the corrupt data, remove it from the table.
  8. Close the database in Microsoft Access.
  9. Open the database in iBase designer.
  10. Attempt the upsize process again.
[{"Product":{"code":"SSXW43","label":"i2 iBase"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.5;8.9.1;8.9;8.9.11;8.9.11.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

More support for:
i2 iBase

Software version:
8.9.5, 8.9.1, 8.9, 8.9.11, 8.9.11.1

Operating system(s):
Windows

Document number:
290785

Modified date:
16 June 2018

UID

swg21998023