IBM Support

IBM i2 iBase the Database Configuration utility requires a password to open the security database

Troubleshooting


Problem

During the iBase database migration to a different SQL server, a requirement is to reestablish the security file, by opening the iBase security file (*.ids) in the Database Configuration Utility tool.

However, when the Database Configuration Utility tool opens the ids in the new environment, for the first time, it can throw an error message, "iBase was unable to connect to the security database. Please enter the database password for this security file to confirm that you have security administrator permissions".
error

Cause

This behavior is expected in the software. The user is required to enter the actual "database password". This is the randomly generated, 14 character password for the idb file.

Resolving The Problem

Follow these steps to resolve the problem:

Step 1: Go back to the old environment, and then open the idb in iBase Designer.

Step 2: In iBase Designer, go to "Tool" -> "Feature availability" -> "Options
option menu

Step 3: In the "Option" menu, click the "Advanced" tab. Observe the 14 character password in the "Database Password" section, which is at the bottom of the menu. Write down the password.
password

Step 4: Now go back to the new environment. Launch the Database Configuration Utility tool, open the ids, and then enter the admin credentials to create the error message. Once the error message appears, enter the 14 character password that was recorded in step 3, into the provided space at the bottom section of the error message (the space is highlighted in yellow in the below screen capture).

enter password

Step 5: Afterward, the ids can open successfully in the Database Configuration Utility Tool.

opened

Document Location

Worldwide


[{"Type":"MASTER","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXW43","label":"i2 iBase"},"ARM Category":[{"code":"a8m50000000Ci9uAAC","label":"i2 iBase and i2 Analyst's WorkStation->Database->Migration"}],"ARM Case Number":"TS005760664","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions"}]

Document Information

More support for:
i2 iBase

Component:
i2 iBase and i2 Analyst's WorkStation->Database->Migration

Software version:
All Versions

Operating system(s):
Windows

Document number:
6459885

Modified date:
29 June 2021

UID

ibm16459885