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IBM i2 Analyst's Notebook throws error "Failed to save document" when attempting to save

Troubleshooting


Problem

When attempting to Save an Analyst's Notebook (ANB) chart, you get an error message "Failed to save Document".

You are still able to execute a Print to PDF or Save to Picture.

You cannot create a new standard chart, then copy from the existing chart and save it to the new chart... same error. In fact, creating a blank chart or a chart with only one entity will result in the same error.


The problem chart was manually created with simple entities and links, having around 88 entities and 144 links. The chart size is under 300K. There is nothing unusual about that.

The predicament is that you need to keep using this chart for the current project, but at some point  a mandatory reboot of your system is coming and you do not want to have to rebuild this chart from scratch.

Cause

It is likely that the issue occurs when saving to a network drive due to some network glitch.

Resolving The Problem

To resolve this issue:

- copy the Chart
- paste into a new Chart to verify that it is in the clipboard
- check that Word also sees it as in the clipboard or that it can be copied into Word "Picture as Bitmap"
- shut down ANB
- open ANB
- paste into new chart
      - if paste step works, attempt to save
            - if save works, issue is resolved
            - if save fails, then we need to "Repair" ANB or uninstall and reinstall ANB, then attempt paste again
      - if paste step fails, then this chart is lost as far as being in an .anb format

 

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Document Information

Modified date:
25 September 2018

UID

ibm10732914