Troubleshooting
Problem
Find Matching Entities function in i2 Analyst's Notebook is unable to detect matching entities.
Symptom
On a i2 Analyst's Notebook chart, the user has a number of entities with the same label and name, but Find Matching Entities function cannot detect them as a match. Moreover, Find Matching Entities still cannot detect these entities as a match even if the threshold is reduced to 1 or 2.
The problem is occurring only for a particular user(s), other users are not affected.
Cause
The problem is caused by corrupted user registry key for i2 Analyst's Notebook.
Diagnosing The Problem
There are a number of ways to diagnosing the problem:
- Save the chart, and then ask the affected user to log on to another i2 Analyst's Notebook machine. Open the same chart, and then see if the Find Matching Entities function can detect a match.
- Ask other users to log on to the i2 Analst's Notebook machine, open the same chart, and observe if the Find Matching Entities function can detect a match.
If the tests indicate the issue is affecting only one user (or only particular users and not all users), then the issue could be caused by the user registry key.
Resolving The Problem
The user can resolve the issue by deleting the i2 Analyst's Notebook registry key and then regenerate it. Follow these steps:
Step 1: Log on to the i2 Analyst's Notebook computer as the affected user
Step 2: Make sure i2 Analyst's Notebook is shut down
Step 3: On the Windows desktop, go to "start", and type in "regedit". This will open the registry key editor
Step 4: In registry editor, navigate to, "HKEY_CURRENT_USER\Software\i2\Analyst's Notebook 7", and delete the entire "Analyst's Notebook 7" folder.
Step 5: Restart ANB, and it will recreate the HKEY_CURRENT_USER\Software\i2\Analyst's Notebook 7 for the affected user.
Find Matching Entities function should start to work again after the user registry key is regenerated.
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"9.2.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]
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Document Information
Modified date:
08 November 2019
UID
ibm11096582