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IBM i2 Analyst's Notebook fails to launch due to Windows Defender Blocking it

Troubleshooting


Problem

You try launching i2 Analyst's Notebook (or another i2 product like i2 iBase) but it fails to launch.  You don't even see the splash screen.

Symptom

Nothing appears to happen when you try launching i2 Analyst's Notebook.

Cause

Windows Defender (or it could be some other 3rd party anti-virus software installed on your machine) is blocking i2 Analyst's Notebook from launching.

Resolving The Problem

1)  Open the Control Panel.
2)  Click on System and Security and there should be a Windows Defender option.  In my screenshot I have the Control Panel items viewed by Category (not big or small icons), click on the Allow an app through Windows Firewall option.
image
3)  Then, in the screenshot below, Dialog 1 (Allowed Apps) opens.  If i2 Analyst's Notebook is in the list of apps check the Private box to allow it through, click OK.   Go to Step 8.
4)  If  i2 Analyst's Notebook is not in the list, click the Change Settings button, then the Allow another App button further down the dialog, Dialog 2 opens.
5)  Click the Browse button and Dialog 3 opens where you can navigate to the ANB.exe file in the folder, similar to C:\Program Files (x86)\IBM i2 ANB Premium 9\ANB.  Select it and click OK to return to Dialog 2.
6)  Click Add in Dialog 2 to return to Dialog 1.
image
7)  Then i2 Analyst's Notebook should appear in the list. Check the Private box and click OK.
image
8)  Click OK and Close out of the Control Panel.
9)  Reboot your machine
10)  Try launching i2 Analyst's Notebook  and hopefully, it launches successfully.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
26 March 2019

UID

ibm10878454