Troubleshooting
Problem
On some occasions, when a user tries to perform an action on iBase (for example a Search or the creation of a new record) from Analyst's Notebook (ANB), ANB does not seem to respond and is like frozen.
User clicks on ANB, but nothing happens.
Only way to close iBase is by using the Task Manager and "kill" the ANB process.
Symptom
This problem mainly occurs when the user is usually using 2 (or more) monitors to work, but for some reason is currently only using one monitor.
This can be, for example, if he's working on a laptop connected to a secondary monitor, and he then has to work outside his office, only on his laptop.
Or it maybe because his second monitor is turned off, or not working.
If the computer has a sound card, when the user clicks on ANB and ANB seems to be frozen, there is a Windows sound being played. This sound is to let the user know that he's not clicking on the correct window.
Cause
When ANB opens an iBase window as a pop-up window, it stores the position of this window on the screen it uses in the Registry key.
Which means that if you are using 2 screens, and the pop-up window is displayed on the second screen, ANB will remember that it must display the windows on the second screen (even if the main ANB window is on the first screen).

This means that if the second screen is unavailable, iBase will still try to display the window on the expected location. However, iBase cannot know that the second monitor is not present.
So, for iBase, the pop-up window is displayed, and it's expecting an action from the user.

For the user, of course, the pop-up window is not displayed on his main (and now only) screen. All he can see if the main ANB window.
And of course, the user cannot click on this "hidden" pop-up window to close it.
Environment
This problem mainly happens when using 2 monitors, and then switching to working on only one monitor.
But we've seen instances of this happening even when the user always used one screen.
Diagnosing The Problem
Usually, pressing the Esc key (on the keyboard) will close the hidden pop-up window.
Also, you can listen at the sound Windows makes if you click the main ANB window, while another window is waiting for an input.
You can easily get this sound if you perform the following :
- Start iBase. Don't connect to the Security file, and don't open any iBase DB
- In the File menu, click Logon.
- A new window will be displayed, to ask you to select the Security file. Do not select the IDS file.
- With this window still open, click the iBase window, on the background.
- You'll hear a small sound (like 3 notes).
This is the Windows sound that tells you that you are not clicking the correct window (this is not limited to ANB or iBase. Other software will behave the same).
If you have this exact same sound when iBase is "frozen", then this most probably means that there is indeed an hidden windows, desperately waiting for the user to use it...
Resolving The Problem
To resolve the problem, you need to make the hidden windows appear on the main screen.
To do this :
- Click the ANB Window. You may hear a sound. This is normal
- Press the Alt+Space keys which will show the Window menu
- Press M, or click the Move menu item
- Tap one of your cursor keys (up/down/left/right), for example the down arrow; which will lock the window to your mouse cursor
- You can them move you mouse cursor and the window will come along with it
- Drop it where you please, with a click of the mouse
The new position of the pop-up window is now saved by iBase, which will use this new position from now on.
If this still doesn't fix the problem, then contact the IBM i2 Support and raise an IBM Support Case.
Document Location
Worldwide
[{"Type":"SW","Line of Business":{"code":"LOB24","label":"Security Software"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"ARM Category":[{"code":"a8m50000000CavkAAC","label":"i2 Analyst's Notebook and other i2 software->General"}],"ARM Case Number":"TS005625455","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Version(s)"}]
Was this topic helpful?
Document Information
Modified date:
20 May 2021
UID
ibm16454811