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IBM i ACS Windows Install Scripts Examined

Question & Answer


Question

What do the IBM i Access Client Solutions (IBM i ACS) Install Scripts for Windows do, and how do they do that?

Cause

The IBM i Access Client Solutions (IBM i ACS) Install scripts are intended to provide ease of use tools to deploy IBM i ACS on the client workstation.  The most function is provided with the scripts for Windows and this document will focus on what is done in that environment.

Answer

The IBM i Access Client Solutions (IBM i ACS) client base package is not installed into the Windows Operating System, in that it does not have a Windows Installer program and it is not registered in Programs and Features and does not show up under Start -> All Programs.

IBM i ACS is deployed to the Windows user's environment, which means that the product files are placed in a location where they will be launched from and configurations are made which make launching the client accessible to the user.  All of this can be done manually in various ways that our client's may choose.  This approach provides significant flexibility, but along with that comes some complexity.

Within this environment IBM has provided install scripts to provide a more standard and simplified deployment approach to getting the client rolled out in the client workstation environment and this document will focus on using these tools within the Windows environment.

The IBM i ACS install scripts for the Windows OS are located in the IBM i Access Windows_Application folder.  There are 5 scripts provided:

  • install_acs_32.js  -  (32bit current user deployment)
  • install_acs_32_allusers.js  -  (32bit all users deployment)
  • install_acs_64.js  -  (64bit current user deployment)
  • install_acs_64_allusers.js  -  (64bit all users deployment)
  • uninstall_acs.js  -  (uninstalls the previous deployment)
     

The bitness of the install script should match the bitness of Java installed on Windows, and it is recommended that the bitness of Java match the bitness of the Windows OS.

One of the initial things the install scripts do is create an install log called "install_acs_log.txt".  By default this log file will be created in the installing user's folder  (C:\Users\<currentwindowsuser>\IBM\install_acs_log.txt).  If that location is not accessible then the install log will be attempted to be written to an alternate location.  Here is where those are:

  • Current user install  -  (Windows %temp% folder)
  • All users install  -  (C:\Users\Public\IBM)


By default the install scripts copy the IBM i ACS deployment from the source install location to the following location on the client workstation:

  • Current user deployment installs to the user's HOMEPATH location, which is normally:
    (C:\Users\<currentwindowsuser>\IBM\ClientSolutions)
  • All users deployment:          (C:\Users\Public\IBM\ClientSolutions)


Another step of the install scripts will ask the individual installing the client what options of the client they want to use or not use, and finally if they want IBM i ACS desktop icons to be created.  Then the product configuration will be updated to reflect those choices.

As the install script progresses it then registers file associations with the Windows OS so that files with the following IBM i ACS extensions are launched with the just installed deployment:

  • .hod  -  (5250 display and printer emulation sessions)
  • .bchx  -  (5250 multiple sessions batch file)
  • .dtfx  -  (Data Transfer from the IBM i OS)
  • .dttx  -  (Data Transfer to the IBM i OS)
  • .sql  -  (Run SQL Scripts)


These file associations are created by using a command line call to the IBM i ACS launch executable that matches the bitness of the install script ran, from the installed location with parameters to set the file associations.  The syntax looks like this:

  • 32bit  -  Start_Programs\Windows_i386-32\acslaunch_win-32.exe  /PLUGIN=fileassoc  hod  bchx  dtfx  dttx  sql
  • 64bit  -  Start_Programs\Windows_x86-64\acslaunch_win-64.exe  /PLUGIN=fileassoc  hod  bchx  dtfx  dttx  sql


Due to this process of setting file associations calling a launch of the IBM i ACS client several things are done that would be done whenever IBM i ACS is launched for the very first time on a Windows workstation.  Examples are:

  • End User License Agreement is posted for review and acceptance.
  • The Configuration Root file system location is created where the user's configuration will be stored.  By default this is the user's Personal Documents folder (C:\Users\<currentwindowsuser>\Documents\IBM\iAccessClient.
  • Java Jar Cache is created for faster startup of the same version of the client from the same location.
  • Other IBM i ACS run-time actions like AutoImport.


If so requested, the install scripts will create 2 desktop icons.  One called "Access Client Solutions" that launches the Main User Interface, and another called "ACS Session Manager" that launches the 5250 Session Manager.

Note:  IBM i Access Client Solutions client must be run within a client workstation user environment.  Therefore, deployment infrastructure mechanisms that must run as a Service or under the System account where the HOMEPATH is not populated will not work running our IBM i ACS install scripts and are currently not supported in this type of environment.

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Document Information

Modified date:
01 April 2024

UID

ibm10729385