Troubleshooting
Problem
When using the Administration Console for Content Platform Engine (ACCE) plugin for IBM Content Navigator (ICN) and trying to log into the ICN admin desktop, the CPE server ICN is configured to connect to can hang with 100% CPU load, making the application unresponsive. No errors are logged. This is due to an incorrect ACCE plugin reference in the ICN configuration database that needs to be deleted and cleanly re-added.
Symptom
An environment is configured to use the ACCE.jar plugin to enable ACCE as a feature in ICN as per the following documentation:
https://www.ibm.com/support/knowledgecenter/en/SSGLW6_5.2.1/com.ibm.p8.ce.admin.tasks.doc/p8pcc241.htm
After an upgrade or system change operation, the following behaviour occurs:
When an admin user is trying to log into the ICN admin desktop, the CPE server configured as repository in ICN hangs with 100% CPU load for 30 minutes or longer.
Cause
This issue is due to an incorrect plugin configuration in ACCE. The reference to the ACCE.jar plugin may be broken or has been replaced with reference to another plugin.
Environment
IBM Content Navigator 2.0.3.x
IBM FileNet Content Manager 5.2.1.x
CPE and ICN deployed on separate operating systems.
Resolving The Problem
Shut down the CPE server. You should be able to successfully access the admin desktop without any hang now. Go to "Plugins" and fully remove (do not just disable) the entry for the ACCE plugin and any other plugins you may have manually modified. Save the changes and refresh the page to confirm that the entries have been removed. Shut down the ICN server and clear application server caches. Restart both the CPE and ICN servers and re-add the plugins required for your environment in the ICN admin desktop.
Related Information
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Document Information
Modified date:
17 June 2018
UID
swg22008574