IBM Support

IBM FileNet Configuration Manager fails to connect to WebLogic

Troubleshooting


Problem

Cannot connect to WebLogic with IBM FileNet Configuration Manager.

Symptom

Setting the application server settings results in an error when trying to populate the 'Target name' filed.
'Connection error: Unhandled exception in lookup'.

Cause

The checkbox in the WebLogic admin console for 'Enable Administration Port' has been enabled.

Environment

Weblogic 11g and 12c.

Diagnosing The Problem

Unable to connect to the WebLogic server instance using FileNet Configuration Manager.
Error: 'Connection error: Unhandled exception in lookup'.

Resolving The Problem

1. Log into WebLogic admin console.
2. Under 'Domain Structure' select the WebLogic domain name.
- This brings up the 'Settings for <your domain>' page.
3. Uncheck 'Enable Administration Port'.


4. Start IBM FileNet Configuration Manager and go to the 'Application Server' properties page.
5. Ensure that the connection to the WebLogic server is successful and that the 'Target name' field is populated via the drop down with the jvm's of the server instance.

[{"Product":{"code":"SSNW2F","label":"FileNet P8 Platform"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"5.1;5.2;5.2.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg22002198