IBM Support

IBM Datacap Navigator 9.0 upload step will return error if Windows IIS Manager enabled WebDAV

Troubleshooting


Problem

In the upload step, IBM Datacap Navigator 9.0 will return HTTP error 405.

Symptom

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET4.0C; .NET4.0E; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Timestamp: Wed, 20 May 2015 06:38:04 UTC

Message: 'mid' is null or not an object
Line: 773
Char: 13
Code: 0
URI: http://xxx.xxx.xxx.xxx:9080/navigator/dojo/dojo.js.jgz

Cause

This error is caused by WebDAV enabled in Windows Internet Information Services(IIS) server, which will block the "PUT" request to IIS server.

Environment

Windows Server 2008 R2

IBM Datacap Navigator 9.0.1

IBM Content Navigator 2.0.3

Resolving The Problem

1. In Windows IIS Manager, select the web site which configured tmweb.net. By default, select Default Web Site, and then open WebDav Authoring Rules and then select Disable WebDAV option present on the right bar.
2.(optional) Back to Default Web Site, and then select Modules, find the WebDAVModule and remove it.
3.(optional) Back to Default Web Site, and then select HandlerMapping, find the WebDAV handler and remove it.
4. Restart IIS.

[{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU056","label":"Miscellaneous"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}}]

Document Information

More support for:
IBM Content Navigator

Document number:
265139

Modified date:
19 August 2022

UID

swg21903606

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