Troubleshooting
Problem
I cannot access my Content Collector web application. The SystemOut.log file is showing this error: "Unable to initialize Struts ActionServlet due to an unexpected exception or error thrown". How can I resolve this?
Symptom
In the SystemOut.log file, the following error can be seen:
[8/5/09 12:18:21:837 PDT] 00000012 SystemOut O A problem occured while accessing the configuration
[8/5/09 12:18:21:837 PDT] 00000012 ActionServlet E org.apache.struts.action.ActionServlet init Unable to initialize Struts ActionServlet due to an unexpected exception or error thrown, so marking the servlet as unavailable. Most likely, this is due to an incorrect or missing library dependency.
javax.servlet.ServletException
at com.ibm.afu.startup.StartupPlugin.init(StartupPlugin.java:111)
at org.apache.struts.action.ActionServlet.initModulePlugIns(ActionServlet.java:869)
at org.apache.struts.action.ActionServlet.init(ActionServlet.java:336)
at javax.servlet.GenericServlet.init(GenericServlet.java:256)
...
at com.ibm.ws.util.ThreadPool$Worker.run(ThreadPool.java:1473)
Cause
This error can occur if the needed parameters in Configuration Manager are not set.
Resolving The Problem
Make sure to specify all needed parameters in Config Manager. Verify the parameters for the following objects set in Configuration Manager:
- Email Services -> Information Center
- Email Services -> Search Application
- Email Services -> Web Application
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Document Information
More support for:
Content Collector
Software version:
2.1
Operating system(s):
Windows
Document number:
394849
Modified date:
17 June 2018
UID
swg21396896