IBM Support

IBM Content Collector Task Routing Engine service failed to start

Troubleshooting


Problem

IBM Content Collector Task Routing Engine service failed to start and there are no task route service logs getting generated.

Symptom

    The following error is logged in Windows application event log:


    An error occurred while attempting to initialize the task routing
    engine: The mutex "Global\IBM_COM_CTMS_CFGSTORE_MUTEX" could not be
    created or opened

    Reason: The mutex "Global\IBM_COM_CTMS_CFGSTORE_MUTEX" could not be
    created or opened

    Source: ibm::ctms::taskrouting::TaskRoutingService::OnStart
    (taskroutingservice.cpp:830)

    Thread: ServiceMain

    Stack Trace:
    (class ibm::ctms::datastore::DataStoreException)
      at ibm::ctms::datastore::ConfigurationStore::getMutex
    (configurationstore.cpp:69),
      at ibm::ctms::datastore::ConfigurationStore::loadStore
    (configurationstore.cpp:118),
      at ibm::ctms::datastore::ConfigurationStore::ConfigurationStore
    (configurationstore.cpp:20),
      at ibm::ctms::taskrouting::CreateDataStore (createdatastore.cpp:
    130),
      at ibm::ctms::taskrouting::TaskRoutingService::OnStart
    (taskroutingservice.cpp:774),
      at ibm::ctms::connector::WindowsServiceBase::ServiceMain
    (windowsservicebase.cpp:104),
      at sechost.dll:0xb5e7,
      at KERNEL32.DLL:0x17c03,
      at ntdll.dll:0x5ad5e,
      at ntdll.dll:0x5ad29,

Cause

The user account starting the task routing engine service does not have sufficient permission.

Environment

IBM Content Collector

Diagnosing The Problem

Ensure the user account starting the task routing engine service is a local administrator on the IBM Content Collector server. For details, refer to this page of the documentation:

Resolving The Problem

Add the user account starting the task routing service to local administrators group and provide any other required permissions as documented.

Related Information

[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"All Content Collector products","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0;4.0.1;4.0.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
Content Collector

Software version:
4.0, 4.0.1, 4.0.1.2

Operating system(s):
Windows

Document number:
542017

Modified date:
17 June 2018

UID

swg21976848

Manage My Notification Subscriptions