IBM Support

IBM Content Collector SharePoint Connector service fails with access denied error.

Troubleshooting


Problem

IBM Content Collector SharePoint Connector service logs have access denied errors and these errors keep repeating.

Symptom

The following errors are logged in the SPConnector logs:

Error 0xc40 Access to pipe \\.\pipe\ibm.ctms.taskroute.datacollector was denied.
ibm::ctms::connector::CreatePipeFile (createpipe.cpp:124)
Trace2 0xc40 Sleeping because create pipe
\\.\pipe\ibm.ctms.taskroute.datacollector returned with code : 5
ibm::ctms::core::log::Write<std::basic_string<wchar_t,std::char_traits<wchar_t>,std::allocator<wchar_t> >,unsigned long> (log.h:78)

Cause

The account starting the ICC SharePoint connector Service does not have sufficient permissions

Environment

IBM Content Collector

Diagnosing The Problem

It is recommended that the user account starting the ICC SharePoint service needs to be local administrator on the IBM Content Collector Server.

Resolving The Problem

Add the user account starting the IBM Content Collector SharePoint service to local administrators group.

[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Collector for Microsoft SharePoint","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21978131