IBM Support

IBM Cognos Mobile application logging on an iPad device

Question & Answer


Question

How to enable logging and download the log files for the IBM Cognos Mobile application on an Apple iPad device?

Cause

When logging is enabled for the Cognos Mobile iPad application, the log files that are generated can help you investigate and debug issues associated with running the application on an iPad device.

Answer

To enable logging for a Cognos Mobile iPad application, do the following steps:

1. On your iPad device, go to Settings.
2. In the Apps section, and select IBM Cognos.
3. On the right pane, tap on Support Settings.
4. For Level of Detail, select the required level of logging.
5. Turn on logging.
For more information, see the section about logging in the IBM Cognos Mobile Installation and Administration Guide (http://pic.dhe.ibm.com/infocenter/cbi/v10r2m0/topic/com.ibm.swg.ba.cognos.ig_mob.10.2.0.doc/c_mob_native_diags_ipad.html).

Once logging is enabled, reproduce the problem that you wanted to investigate or debug. The Cognos Mobile log files that are created on the iPad device will help you understand and resolve the issue. To view the log files, you must download them from the iPad device to your computer using iTunes. You can do this in the following way:

1. Using the iPad cable, connect your iPad to a computer that has Apple iTunes installed.
2. From iTunes, select your iPad
3. Under the Apps tab, go to File Sharing >Apps>IBM Cognos Mobile.
4. Under IBM Cognos Documents, select the SupportArtifacts folder.
5. Click Save, and save the folder to a directory on your computer.

You can now view the log files in the SupportArtifacts folder on your computer to analyze them by yourself, or send the files to IBM support if you need assistance with resolving your issue. The files are in a text format.

Important: The log files in the SupportArtifacts folder might contain sensitive information, such as user names or passwords. Check the contents of the folder and remove any sensitive information before delivering the files to IBM. Using the search and replace function in your text editor might help you with this task.

[{"Product":{"code":"SSEN9H","label":"IBM Cognos Mobile"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Cognos Mobile","Platform":[{"code":"PF014","label":"iOS"}],"Version":"10.1.1;10.2","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
04 September 2019

UID

swg21614419