IBM Support

IBM Case Monitor Dashboard and Chart widget must be configured to support screen readers

Question & Answer


Question

Why can't my screen reader read a chart that is used in IBM Case Monitor Dashboard or in the Chart widget?

Cause

The charts that are used in IBM Case Monitor Dashboard and the Chart widget are not configured to enable accessibility, which prevents the screen reader from reading the chart data.

Answer

To enable accessibility for all uses of IBM Case Monitor Dashboard:

  1. Log in to IBM Content Navigator administration tool, click Plug-ins, and double-click IBM Case Monitor Dashboard plug-in.
  2. Select the Enable accessibility check box.
  3. Click Save.

Alternatively, you can enable accessibility for an active session by appending the keyword &access=true to the URL as shown in the following example:

http://localhost:9080/navigator/?desktop=icmmonitor&access=true

To enable accessibility in the Chart widget:
  1. Open the page on which the Chart widget is used in Page Designer.
  2. In the Chart widget, click the Settings icon.
  3. Select the Enable accessibility check box.
  4. Save the page.

[{"Product":{"code":"SSCTJ4","label":"IBM Case Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"5.3.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg22004482