IBM Support

The IBM Case Manager Client Case History tab is slow sometimes when the Content Engine database is IBM DB2

Troubleshooting


Problem

When viewing the History tab in the Case Information widget in IBM Case Manager Client, if the case has a large number of case history records associated with it and the Event table in Content Engine has a large number of records, the views might load very slowly. Sometimes the following timeout error occurs, with very slow responses: The case history is unavailable because of the following error: timeout exceeded (CDEWG5206E)

Symptom

Open a case in the IBM Case Manager Client and go to the History tab in the Case Information widget. As you change the views, such as "Show Summary/All" and "for All/Case/Comments/etc.", they load very slowly, for example, nearly in one minute.

Cause

The information displayed on the History tab is stored in the Event table in the Content Engine database. The Event table index might not have been updated or configured to fit your environment needs. This causes a database performance problem.

Environment

IBM Case Manager Version 5.0 and later; DB2 9.7 database

Resolving The Problem

In the Content Engine database, delete the existing indices for the Event table, including those that were included with the out-of-the-box configuration. Create one new index with the following definition:

    "CREATE UNIQUE INDEX I_CASE_FOLDER
    ON db2admin.EVENT (U88E7_CMACMCASEFOLDER ASC, AUDIT_SEQUENCE DESC)
    INCLUDE (OBJECT_CLASS_ID, SOURCE_OBJECT_CLASS_ID, HOME_ID)
    COMPRESS NO ALLOW REVERSE SCANS"

The sample steps below provide a procedure for the index change. In the sample, the existing Event table indices that need to be deleted are the following: INDEX I4, INDEX I_CASE_FOLDER, DROP INDEX I_CASE_FOLDER_2 :
  1. Ask your database administrator to apply the following DB2 index changes in the Content Engine database:
    a. db2 "connect to <DBNAME> user <userid> using <password>
    b. db2 "DROP INDEX I4"
    c. db2 "DROP INDEX I_CASE_FOLDER"
    d. db2 "DROP INDEX I_CASE_FOLDER_2"
    e. db2 "CREATE UNIQUE INDEX I_CASE_FOLDER ON <owner>.EVENT (U88E7_CMACMCASEFOLDER ASC, AUDIT_SEQUENCE DESC) INCLUDE (OBJECT_CLASS_ID, SOURCE_OBJECT_CLASS_ID, HOME_ID) COMPRESS NO ALLOW REVERSE SCANS"
    f. db2 "commit"
  2. Perform a RUNSTATS command on the Event table:
    db2 "runstats on table <owner>.EVENT with distribution and detailed indexes all"
  3. Execute the following db2 commands:
    1. db2 "flush package cache dynamic"
    2. db2 "reset monitor all"

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Product Synonym

IBM Case Manager;Case Manager;Advanced Case Management

Document Information

Modified date:
17 June 2018

UID

swg21587662