Troubleshooting
Problem
Sometimes srcmstr may not be able to communicate with its subsystems. For example, running "stopsrc -s <subsystem>" may not stop the subsystem.
Symptom
The subsystem will not respond to any queries. It will not log any information.
Cause
The subsystem may be hung while waiting for a resource that is being used by another process or is otherwise not available now.
Diagnosing The Problem
Collect the following information from the customer.
1) Output from this command.
odmget -q 'subsysname="<subsystem>"' SRCsubsys
For example:
odmget -q 'subsysname="sshd"' SRCsubsys
2) Attach truss to the unresponsive subsystem and gather any output. For example:
truss -o /tmp/subsystem.truss -p <subsystem_pid>
3) Get pdump.sh output from the subsystem. This script may be downloaded from ftp://ftp.software.ibm.com/aix/tools/debug/pdump.sh. Do not use any options with pdump.sh--just supply the subsystem's PID.
The odmget command will display all of the subsystem's SRC options. Ensure that the command line parameters, if any, are correct. Now gather the same output from a lab systems at the same AIX level and compare them. Any parameters with different values might be the cause of the problem.
The truss output may show the system call or resource the subsystem is waiting on. If the subsystem is hung in a way that it cannot wake up from, there will be no truss output. In this case, the output from pdump.sh will show the exact library and/or system call in which the subsystem is hung.
As an example scenario, some subsystems, such as iptrace and aixmibd, write messages to the console. If the console itself is hung (for example, swcons has been used to redirect console output to a different device and that device is unresponsive), any subsystem trying to write to the console will also hang.
Resolving The Problem
Determine where the subsystem is hung and continue diagnosis from there.
Document Location
Worldwide
[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG10","label":"AIX"},"Component":"","Platform":[{"code":"PF002","label":"AIX"}],"Version":"","Edition":"","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]
Was this topic helpful?
Document Information
Modified date:
31 May 2019
UID
ibm10885370