Troubleshooting
Problem
You are upgrading an IBM i2 iBase database by using iBase designer 9.0.3 and want to check progress
Symptom
You are upgrading an IBM i2 iBase database by using iBase designer 9.0.3 and the upgrade is taking longer than anticipated or appears to stop.
Cause
It might be a large database.
There might have been a problem with the upgrade.
Environment
Upgrading, from iBase 8.x to iBase 9.x you
- Must first move to iBase 8.9.13 and open the database in iBase 8.9.13 iBase designer
- Then, apply the upgrade to iBase 8.9.13 using iBase 8.9.13 iBase designer
Then, you can repeat the upgrade steps on the database by using iBase designer 9.x
Diagnosing The Problem
With iBase 9, applying the upgrade to the database in iBase designer, creates an upgrade log in the folder containing the iBase database idb file.
The file name is of the format iBase_upgrade_<timestamp>.log
You have a timestamped log for every database idb in the folder that is upgraded to iBase 9.x.
You have a timestamped log for every time you upgrade the same database for different release versions of iBase 9.x.

The file location and file name of the idb file for the upgraded iBase database is recorded in the first line of the upgrade log.
Resolving The Problem
Things to consider:
If the database upgrade is still progressing, then access to read the log file can be prohibited. This can be one indicator that work is still being performed in the upgrade and to allow more time for the upgrade to complete.
If the log file contains entries referring to LINK End Updates such as
Start Link End Update 1
End Link End Update 1
Start Link End Update 2
End Link End Update 2
Start Link End Update 3
End Link End Update 3
Start Link End Update 4
End Link End Update 1
Start Link End Update 2
End Link End Update 2
Start Link End Update 3
End Link End Update 3
Start Link End Update 4
Then, for each 'Start Link End Update'; there should always be a corresponding 'End Link End Update'.
If there is a missing END Link End Update, then it can indicate the upgrade still has work to complete, or it was interrupted.
Interpretation of the log file content can be difficult. We would recommend opening a Support case with IBM Support. Please supply the upgrade log with any case involving an iBase 9.x upgrade problem
Related Information
Document Location
Worldwide
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Document Information
Modified date:
20 July 2021
UID
ibm16473655