Troubleshooting
Problem
Unable to authenticate to Information Analyzer
Symptom
User gets: "An unknown error has occurred while attempting to log in"
Cause
Lack of permissions or invalid registered-servers.xml file.
Diagnosing The Problem
When trying to connect user gets:
Authentication Failed
An unknown error has occurred while attempting to log in.

On the detailed error message it shows:
[ERROR] [MOZART-UI-00063] Unexpected exception encountered while attempting to authenticate "<user namer>" against server "<server name>"
IBM.Mozart.Platform.UserAuthenticationException: Unknown ---> Com.Ascential.Acs.Registration.Client.FileLockException: <JavaException>
<Type>com/ascential/acs/registration/client/FileLockException</Type>
<Message><![CDATA[Could not acquire lock on file "C:\Program Files (x86)\IBM\InformationServer\ASBNode\eclipse\plugins\com.ibm.isf.client_8.5.0.0\registered-servers.xml".]]></Message>
<StackTrace><![CDATA[com.ascential.acs.registration.client.FileLockException: Could not acquire lock on file "C:\Program Files (x86)\IBM\InformationServer\ASBNode\eclipse\plugins\com.ibm.isf.client_8.5.0.0\registered-servers.xml".
at com.ascential.acs.registration.client.RegistrationHelper.lockRegisteredServerFile(RegistrationHelper.java:457)
at com.ascential.acs.registration.client.RegistrationHelper.lockRegisteredServerFile(RegistrationHelper.java:404)
at com.ascential.acs.registration.client.RegistrationServiceHelper.registerServerWithNode(RegistrationServiceHelper.java:952)
Caused by: java.io.FileNotFoundException: C:\Program Files (x86)\IBM\InformationServer\ASBNode\eclipse\plugins\com.ibm.isf.client_8.5.0.0\registered-servers.xml (Access is denied.)
at java.io.RandomAccessFile.<init>(RandomAccessFile.java:229)
at com.ascential.acs.registration.client.RegistrationHelper.lockRegisteredServerFile(RegistrationHelper.java:455)
Resolving The Problem
It is necessary to;
- Check for user's permissions on the following file:
C:\Program Files (x86)\IBM\InformationServer\ASBNode\eclipse\plugins\com.ibm.isf.client_8.5.0.0\registered-servers.xml
User must have full permission to this folder.
- Check the file size. This is usually 1-2 KB. If, for example, your file shows as 0 KB it will be necessary to copy it from a valid installation and paste it to your computer.
In case the issue still persists, please gather the installation logs and contact IBM InfoSphere Information Server Support for further investigation and troubleshooting.
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Document Information
Modified date:
16 June 2018
UID
swg21638655