IBM Support

i2 Analyst's Notebook error during startup: Failed to start the URL Helper service

Troubleshooting


Problem

I'm getting the following pop-up error when starting up i2 Analyst's Notebook on a system shared by other users (Citrix or Remote Desktop):

Failed to start the URL Helper service. 

Clicking on the Show Diagnostics button displays the following details:

Failed to start the URL Helper service.

System.ServiceModel.AddressAlreadyInUseException: Cannot listen on pipe name 'net.pipe://localhost/i2.Apollo.Notebook.URL/ApolloUrlHelper' because another pipe endpoint is already listening on that name. ---> System.IO.PipeException: Cannot listen on pipe name 'net.pipe://localhost/i2.Apollo.Notebook.URL/ApolloUrlHelper' because another pipe endpoint is already listening on that name.
   --- End of inner exception stack trace ---
   at System.ServiceModel.Channels.PipeConnectionListener.Listen()
   at System.ServiceModel.Channels.BufferedConnectionListener.Listen()
   at System.ServiceModel.Channels.ExclusiveNamedPipeTransportManager.OnOpen()
   at System.ServiceModel.Channels.TransportManager.Open(TransportChannelListener channelListener)
   at System.ServiceModel.Channels.TransportManagerContainer.Open(SelectTransportManagersCallback selectTransportManagerCallback)
   at System.ServiceModel.Channels.TransportChannelListener.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.ConnectionOrientedTransportChannelListener.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.NamedPipeChannelListener`2.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.Dispatcher.ChannelDispatcher.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at System.ServiceModel.ServiceHostBase.OnOpen(TimeSpan timeout)
   at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
   at i2.Notebook.Apollo.Task.DataSourceTask.ApolloDataSourceTask.InitialiseHelperService()

Symptom

After getting the error, sometimes the Analyst's Notebook continues initializing and starts up, however, the user is not able to connect to the Analysis Repository on the i2 Analyze Server, even though the connection can be made outside of Analyst's Notebook from a browser.

Cause

There is a documented limitation in the i2 Analyst's Notebook Release notes

Problem

Description

Unable to use Analyst's Notebook Premium in a Citrix or Remote Desktop Services environment

If you are using Citrix/Remote Desktop Services with Administrator permissions (or SeCreateGlobalPrivilege set), multiple users cannot use the Analyst's Notebook Premium Oynx connector at the same time

 

Environment

Multiple Administration users are logging into the same system (Citrix or Remote Desktop) and trying to use i2 Analyst's Notebook at the same time.

Diagnosing The Problem

For the users which are receiving the error, they can confirm if they have the SeCreateGlobalPrivilege privilege by running the following command :

whoami /priv

This will list the privileges for the current user.


Also from the Local Security Policy tool (from the commandline: secpol), open Local Policies -> User Rights Assignment
Double click on the "Create Global Objects" Policy to see the list of Users and Groups which have the SeCreateGlobalPrivilege privilege.

If more than one person from any of the listed groups uses i2 Analyst's Notebook on the same system, they will get blocked from accessing the named pipe used to communicate to the i2 Analyze Onyx Services.

 

Resolving The Problem

Make sure there is no more than one user with SeCreateGlobalPrivilege accessing i2 Analyst's Notebook on the system at any one time.

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSXVMQ","label":"i2 Analyst's Notebook Premium"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Versions","Edition":"Premium edition","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Product Synonym

ANBP

Document Information

Modified date:
16 October 2018

UID

ibm10735399