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I meet error message when searching users and groups to add Box collaborator in IBM Content Navigator . How to solve it?

Question & Answer


Question

I meet error message when searching users and groups to add Box collaborator in IBM Content Navigator . Following is the steps to reproduce: 1. Open Content Navigator desktop 2. Open Browse View 3. Select Box repository 4. Select one folders and right click 5. Select properties 6. Click security tab 7. Input some character in input box Then, the following error message was displayed: You cannot search for users and groups because the Box application is not configured correctly. To use this feature, contact your administrator and request that the Box application be configured for managing users and groups. So, I could add Box collaborator and only search function did not work.

Cause

There are two possible reason for this error:
1. User did not check the following permissions in OAuth2 Parameters->scopes in Box application setting:
Manage users
Manage groups
2. User did not reconnect to box repository after change OAuth2 Parameters settings. User has to reconnect to Box in admin desktop-repository settings.

Answer

After user modified OAuth2 setting and reconnect Box repository with the following steps, the problem was solved.
1. Modify OAuth2 Parameters->scopes: Manage users/Manage groups
2. User > 'Disconnect Box account'
3. User > 'connect Box account'

[{"Product":{"code":"SSEUEX","label":"IBM Content Navigator"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ICN and Case Manager","Platform":[{"code":"PF033","label":"Windows"}],"Version":"2.0.3.8","Edition":"","Line of Business":{"code":"LOB18","label":"Miscellaneous LOB"}}]

Document Information

Modified date:
16 June 2018

UID

swg22002036