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Human Task Manager predefined task applications for WebSphere Process Server (WPS) fail to start due to Assertion Violation errors

Troubleshooting


Problem

In your WebSphere Process Server (WPS) environment, two Business Process Choreographer (BPC) related applications (HTM_PredefinedTasks_Vnnn_scope and HTM_PredefinedTaskMsg_Vnnn_scope) fail to start during the application server start up process.

Symptom

The log and trace files show the following type of Assertion Violation errors:

[2/2/11 17:18:15:049 MST] 00000017 TraceBPE      E                      
com.ibm.bpe.util.Assert.assertion(Assert.java:66) Assertion violation  
!(Task 'Approval_Request' with valid from '2010-07-01T00:00:00' and    
targetnamespace 'http://com.ibm.htm.predefined' already installed in    
cell 'st1WBPMCell1'.) in method >>                                      
com.ibm.task.deployment.TaskDeployer.installTask(TaskDeployer.java:267)
<<                                                                      
                                                                       
[2/2/11 17:29:16:480 MST] 00000015 TraceBPE      E                      
com.ibm.bpe.util.Assert.assertion(Assert.java:66) Assertion violation  
!(Task 'Message' with valid from '2010-07-01T00:00:00' and              
targetnamespace 'http://com.ibm.htm.predefined' already installed in    
cell 'st1WBPMCell1'.) in method >>                                      
com.ibm.task.deployment.TaskDeployer.installTask(TaskDeployer.java:267)
<<                                                                      

Cause

There are leftover task templates in Business Process Choreographer database that are associated with these two applications. These leftover templates might exist because of some previous issues or changes in your environment.

Resolving The Problem

These two applications have no impact on the Business Process Choreographer environment because they are only sample applications. These "predefined" tasks are shipped so that you can start using Human Tasks without the need to download samples from the sample site and without developing an application in WebSphere Integration Developer (WID). However, these are not part of the BPC Engine.

You have the following options to solve this problem:

  • You can uninstall these two sample applications. This approach does not prevent you from running or testing BPEL applications in your environment.

  • If you want these two applications running in your system, then you must remove their old task templates from the Business Process Choreographer database. To remove them, complete the following steps:
    1. Take a snapshot of the task template table in the BPC database. You should see task templates like Approval_Request and Message in that table.

    2. Run the deleteInvalidTaskTemplate.py script to remove all those task templates. This script is described in the Deleting human task templates that are no longer valid topic within the information center.


      Run the script once for each task template and provide the appropriate parameter values.

    3. Restart your environment when you are certain that no more data associated with those applications exists in the table.


    These two applications should now start.

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Human Task Manager","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"},{"code":"PF012","label":"IBM i"}],"Version":"7.0;6.2;6.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPC

Document Information

Modified date:
15 June 2018

UID

swg21468871