IBM Support

HTTP ADMIN Server Fails to Start with Error HTP8029

Troubleshooting


Problem

The HTTP ADMIN server fails to start and the job log shows an error HTP8029.

Symptom

After starting the HTTP ADMIN server, it fails with the following error in the job log:
HTP8029  Diagnostic       40  01/07/20 16:22:36.496198 QZSRAPR   QHTTPSVR  *STMT  QZSRCORE  QHTTPSVR  *STMT
                   From module . . . . . . . . :  QZSRSNDM
                   From procedure . . . . . . :  sendMessageToJobLog_CCSID
                   Statement . . . . . . . . . :  27
                   To module . . . . . . . . . :  HTTP_CONFI
                   To procedure . . . . . . . :  ap_process_resource_config
                   Statement . . . . . . . . . :  14
                   Message . . . . :  Error occurred opening file.
                   Cause . . . . . :  An error occurred when attempting to open file
                    /QIBM/UserData/HTTPA/admin/conf/admin-cust.conf. As a result, the HTTP
                    server did not start. The error number received was: 3401. Recovery . . . :
                     If the error number is a value other than 0, determine the meaning of the
                    error number and perform the appropriate recovery for that error. Correct
                    the errors and start the HTTP server again. Technical description . . . . .
                    . . . :  Error number (errno) 3401 was received when trying to open the
                    file. To determine the meaning of the error number, do one of the
                    following: - Use DSPMSGD CPExxxx, where xxxx is the error number, to display
                    an error message containing more information about this error number. -
                    Display one of the following files that contain descriptions of error
                    numbers: QSYSINC/SYS, member ERRNO and QCLE/H, member ERRNO.

Cause

We typically see this error happen after an operating system upgrade.  Previous releases of the operating system used Authorization Lists to grant authority to the '/QIBM/UserData/HTTPA/admin/conf/admin-cust.conf' file.  Later versions of the operating system no longer use Authorization Lists on this path and we lack enough *PUBLIC authority to access the file.

Diagnosing The Problem

On the IBM i command line, type the following command:
WRKJOB ADMIN
Display the job log and check for the HTP8029 error message.

Resolving The Problem

To resolve the problem, we can run the following command from the IBM i command line:
CHGAUT OBJ('/qibm/userdata/httpa') USER(*PUBLIC) DTAAUT(*RX) SUBTREE(*ALL)
We then can restart the ADMIN server with the following command:
STRTCPSVR SERVER(*HTTP) HTTPSVR(*ADMIN)

Document Location

Worldwide

[{"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Component":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB57","label":"Power"}}]

Document Information

Modified date:
07 January 2020

UID

ibm11169302