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The HTM_PreDefinedTask applications for WebSphere Process Server (WPS) fail to start up with a NameNotFound exception

Troubleshooting


Problem

After you install and configure a WebSphere Process Server V7.0.0.x clustered environment, two business process choreographer-related applications (HTM_PredefinedTask and HTM_PredefinedTaskMsg) fail to start up after the restart of the environment.

Symptom

The SystemOut log file shows the following errors:

[3/15/12 9:27:07:893 CDT] 00000015 RALifeCycleMa E   J2CA0052E: The lookup of the Activation Specification with JNDI Name  sca/HTM_PredefinedTaskMsg_V7003_CU01-C03-HWC_WPS_AppTargetCluster/ActivationSpec failed due to the following exception: javax.naming.NameNotFoundException: Context: CU01-lkcme0ghpapu1/clusters/CU01-C03-HWC_WPS_AppTargetCluster, name: sca/HTM_PredefinedTaskMsg_V7003_CU01-C03-HWC_WPS_AppTargetCluster/ActivationSpec: First component in name HTM_PredefinedTaskMsg_V7003_CU01-C03-HWC_WPS_AppTargetCluster/ActivationSpec not found. [Root exception is org.omg.CosNaming.NamingContextPackage.NotFound: IDL:omg.org/CosNaming/NamingContext/NotFound:1.0]

 at com.ibm.ws.naming.jndicos.CNContextImpl.mapNotFoundException(CNContextImpl.java:4377)

 at com.ibm.ws.naming.jndicos.CNContextImpl.doLookup(CNContextImpl.java:1806)

 at com.ibm.ws.naming.jndicos.CNContextImpl.doLookup(CNContextImpl.java:1761)

 at com.ibm.ws.naming.jndicos.CNContextImpl.lookupExt(CNContextImpl.java:1512)

 at com.ibm.ws.naming.jndicos.CNContextImpl.lookup(CNContextImpl.java:644)

 at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:166)

 at com.ibm.ws.naming.util.WsnInitCtx.lookup(WsnInitCtx.java:180)

 at javax.naming.InitialContext.lookup(InitialContext.java:436)

 at com.ibm.ejs.j2c.RALifeCycleManagerImpl.activateEndpoint(RALifeCycleManagerImpl.java:1687)

 at com.ibm.ws.container.binding.jms.MessageEndpointFactoryImpl.activateEndpoint(MessageEndpointFactoryImpl.java:264)

 at com.ibm.ws.container.binding.jms.J2CBindingManagerImpl.add(J2CBindingManagerImpl.java:112)

 at com.ibm.ws.container.binding.jms.J2CBindingManagerImpl.add(J2CBindingManagerImpl.java:46)

 at com.ibm.ws.sca.internal.async.handler.AsyncModuleListener.onStarted(AsyncModuleListener.java:78)

 at com.ibm.ws.sca.internal.message.impl.MessageDispatcherImpl.initContentExtensionOnStarted(MessageDispatcherImpl.java:2201)

 at com.ibm.ws.sca.internal.container.impl.ContainerImpl.startModuleComponents(ContainerImpl.java:1157)

 at com.ibm.ws.sca.internal.container.impl.ContainerImpl.triggerModuleComponent(ContainerImpl.java:1122)

................................................................

Cause

The activationSpecs, which are associated with these two applications, are either missing or were generated in a different scope. This issue might be related to a problem in the upgrade process or some previous issues in your environment.

Resolving The Problem

Note: These two applications do not have an impact on the business process choreographer engine. For more information, see the "Resolving the problem" text in the Human Task Manager predefined task applications for WebSphere Process Server (WPS) fail to start due to Assertion Violation errors document.

To resolve this issue, complete one of the following steps:

  • Uninstall these two applications.
  • Complete the following steps if you want to keep these two applications running in your system:
    1. Uninstall these two applications.
    2. Verify that there are no existing activation specifications that are associated with these two applications. You can use the administrative console to verify. Click Resources > JMS > Activation specifications. If you find any existing activation specifications after the uninstall process is complete, delete them.
    3. Reinstall these two applications manually. The deployment target should be the AppCluster, if it is a clustered environment, or AppServer, if it is a stand-alone environment, where business process choreographer is configured. These two applications should be available in one of the following directories:
      • <wps_install_root>\InstallableApps
      • <wps_install_root>\ProcessChoreographer\Internal

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Human Task Manager","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF012","label":"IBM i"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"7.0;6.2;6.1.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

WPS

Document Information

Modified date:
15 June 2018

UID

swg21589144