Troubleshooting
Problem
Customer has a working Controller 10.1.x (10.1.0.x) application server. Customer would like to upgrade their server to a later patch level of 10.1 (for example 10.1 IF9 = 10.1.394). How do they do this?
Symptom
For reference, here are some version numbers of Controller (click "Help - System Info" in Controller, and check the top line):
- 10.1 RTM = 10.1.332
- 10.1 IF1 = 10.1.335
- 10.1 IF2 = 10.1.348
- 10.1 IF3 = 10.1.352
- 10.1 IF4 = 10.1.364
- 10.1 IF5 = 10.1.377
- 10.1 IF6 = 10.1.384
- 10.1 IF7 = 10.1.387
- 10.1 IF8 = 10.1.391
- 10.1 IF9 = 10.1.394
- 10.1 IF10 = 10.1.395
- 10.1 IF11 = 10.1.397
- 10.1 IF12 = 10.1.405
- 10.1 IF13 = 10.1.407
- 10.1 IF3 GA (generally available) = 10.1.409
- 10.1 IF4 GA = 10.1.417
- 10.1 IF5 GA = 10.1.424
- 10.1 IF6 GA = 10.1.?424?
Cause
From version 10.1, the process for patching a server has changed.
- It is now possible to patch the Controller application server *without* having to perform a full uninstall/re-install of the Controller application server software.
However, care needs to be taken (during the patching process) to ensure that all Controller-related services/systems/components are stopped.
Environment
Controller 10.1 RTM (also known as Controller 10.1.332) or later 10.1.0 Interim Fix (IF) release.
Resolving The Problem
Perform the following tasks:
- Download a copy of the latest Interim Fix (IF) patch. TIP: You will need to log a support call with IBM Support to obtain a copy of most IF patches.
- Obtain downtime (no users on system)
- As a precaution, backup all Controller-related databases (application repositories, ContentStore and FAP)
- As a precaution, take a backup of all settings stored inside "Cognos Configuration" and "Controller Configuration"
- Shut down all Controller-related services/components on application server(s) (see later for list of these)
- As a precaution, take a backup of entire c10 folder
- Install Patch Controller 10.1 application server(s)
- Launch "Controller Configuration" and check that all settings look the same as before the upgrade. Most importantly, open section "Report Server". Replace all references saying "http://localhost/...." to "http://<servername>/...." where <servername> is the same name that was used before the upgrade process was run. TIP: Take care to use the same naming convention (NetBIOS or FQDN) that was used before the upgrade. Refer to your printscreen backups that you made in step (3).
- If used ISAPI before upgrade, then change "Report Server" to mention cognosisapi.dll instead of cognos.cgi
- If using ISAPI before the upgrade, then modify the files "default.htm" and "index.html" (located in webcontent folder) to refer to cognosisapi.dll instead of cognos.cgi
- Check that 'frangovfp.dll' has been registered correctly, by following the steps inside Technote #1574741
- Check that 'FrCrypto.dll' has been registered correctly, by following the steps inside Technote #1574744
- Check if the following are ALL true:
- (a) You have upgraded to 10.1 IF7 or later
(b) You are using the Controller FAP functionality
(c) You are using TM1 version 9.x
(d) You are using Cognos (CAM) security.
- If they are ALL true, then you will need to replace the file "...\c10\server\FAP\lib\c8itk4j.jar" with the *old* version (the version before you upgraded).
- In other words, rename the file "...\c10\server\FAP\lib\c8itk4j.jar" to "c8itk4j.jar.101" and then copy the file "c8itk4j.jar" (from the backup folder you created in step 5) to the folder ...\c10\server\FAP\lib.
14. Check the Windows service "IBM Cognos Controller Java Proxy". Ensure that it is configured to 'Log On As' using the correct Windows user (typically the COM+ user e.g. <domain>\Controller_system).
15. IMPORTANT: Check the application server to make sure that it has a registry key "STAThreadPool" (containing "EmulateMTSBehavior" / 00000001)
- TIP: This is a new (from early 2013) IBM recommendation for all customers
- For full details of this registry key, see separate IBM Technote #1621584.
16. Reboot Controller 10.1 application server(s) to start services
17. Upgrade client software on each-and-every end-user's client device.
- TIP: If the client operating system is 64-bit and has 4Gb or more RAM installed, then it is recommended to convert the CCR.EXE to LAA. See separate Technote #1579579 for full details.
More detail on above Steps
**********************************************
TIP: For more details, including printscreens of some of these steps, see attached document "1504613d - How to upgrade Controller 10.1 RTM to a later Interim Fix _IF_ Fix Pack _patch_ level.pdf".
**********************************************
(Step 4) How to shut down all Controller-related services on application server(s)
- Stop the following services:
- IBM Cognos service
- IBM Cognos Controller Batch Server
- IBM Cognos Controller Java Proxy
- IBM Cognos Controller User Manager
- IBM Cognos FAP Service
- Internet Information Services (IIE) Manager (the Default Web Site)
- Components Services IBMCOGNOSCONTROLLER and any other Controller-related COM+ application (e.g. "COGNOSVFP" or "IBMCOGNOSVFP")
Extract the compressed patch file (for example IF3 = up_cntrl_win32_10.1.4801.104_ml.tar.gz)
Double-click on installer file issetup.exe (in subfolder win32).
If the Controller database version has increased (with the new IF3) then use the Database Conversion utility to upgrade your Controller application databases.
Open "IBM Cognos Configuration", save the configuration, and then start the IBM Cognos service.
If you have a distributed environment, repeat these steps for all remaining IBM Cognos BI servers.
Reboot the Controller application server (to automatically start the IIS and Controller-related services).
(Step 17) Upgrade client software on each-and-every end-user's client device.
- Logon to the client device as a Windows administrator
- Launch "Add/Remove Programs" and remove the Controller client (for example "IBM Cognos Controller Local Client")
- Download the new version of the Controller client from the application server (for example "http://SERVERNAME/ibmcognos/controllerbin/ccrlocalclient.msi"). TIP: There are three different versions of the client - see Technote#1371088. For most customers, CCRLocalClient.MSI is the best version to use.
- Double-click on the client installation file (for example "ccrlocalclient.msi")
- Follow the installation wizard.
- TIP: If unsure what values to use (for example WSSUrl) then open the file %APPDATA%\Cognos\CCR\ccr.config inside NOTEPAD and read the values from there,
Related Information
1503593 - "An error occurred... Index was outside the b
4031049 - IBM Cognos Controller 10.1.0 Interim Fix 2
7023201 - Cognos Controller 10.1 Interim Fix 2 Fix List
1371088 - What is the difference between the different
1574741 - "Frangovfp.cglobvar Object was not found in r
1574744 - FrCrypto.dll is not automatically registered
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Document Information
Modified date:
15 June 2018
UID
swg21504613