IBM Support

How to restore the built-in group Everyone to the Role System Administrators

Troubleshooting


Problem

You have locked yourself out of the role System Administrator.

Symptom

You are unable to administer the system anymore.

Cause

No user, group, or role that you currently have access to - has access to Manage or the Administration Console anymore.

Diagnosing The Problem

Access to Manage or the Adminstration Console fails.

Resolving The Problem

  1. Stop the Cognos Analytics Server
  2. Use database tools to create a physical backup of the Content Store state
  3. Use database tools to connect to the content store and run ...\cognosinstallation\configuration\schemas\content\<content_store_vendor>\AddSysAdminMember.sql against the Content Store
    The folder <content_store_vendor> needs to match your Content Store's database vendor.
    After the script ran, the built-in security group Everyone is back in the System Administrator role - at this moment every user is a System Administrator.
  4. Proceed to start the Cognos Analytics Server
  5. Add any eligible users, groups, and roles to the System Administrator role, remove the Everyone group if necessary

 

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Document Information

Modified date:
15 November 2018

UID

ibm10740589