IBM Support

How to restart IBM Cognos Analytics query service [not recommended to so by command line]

Troubleshooting


Problem

If Query Service is restarted by running the script, sometimes the service doesn't start properly and shows an incorrect status of the Query Service.

image-20220712132906-1

Symptom

After successfully restarting the Query Service from the command line, if we run the status command, it is supposed to show that the status of the Query Service is running. However, it doesn't always show accordingly. 

Cause

The Query Service should always be restarted from the Administration user interface - not from the command line where we run a script. 

The reason behind the different behavior of the same status command is as below:

A lot of other services are associated with the Query Service. If we run the stop command - that doesn't always necessarily stop all those processes. That's why the status command might come up with a different/incorrect status. If Cognos is up and running with some reports or jobs, then this command does not really control over as top as high priority action. So, whenever you require to restart the Query Service, do so from the Administration user interface.

Environment

Both Windows and Linux.

Resolving The Problem

The following steps are recommended to the query service restart via the graphical user interface (Cognos administration > Status >System > Scorecard section > All Servers drop-down menu > Services > query > QueryService drop-down menu > Stop/Start).

Document Location

Worldwide

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Document Information

Modified date:
01 September 2022

UID

ibm16603053