Troubleshooting
Problem
When Single Sign On is configured for an IBM i and has been working, sometimes users encounter the following error message when connecting to the system:
MSGSY1018 : Kerberos credential could not be mapped for users.
Or
CWBSY1018 rc 613
Cause
This issue is normally the result of a mismatch between the LDAP and EIM cn=Administrator passwords.
Resolving The Problem
To resolve this issue, I would recommend first checking the LDAP job log on the IBM i. If you are using the default server this job is the QUSRDIR job. Check for a GLD0120 error in the job log. If you find this error continue with the following steps to resolve the issue.
Heritage IBM Navigator for i (V7R2 and below)
NOTE: The steps are done from the IBM Navigator for i page (http://systemName:2004/ibm/console or https://systemName:2005/ibm/console).
Update the LDAP cn=Administrator password:
- Navigate to Network -> Servers -> TCP IP Servers in Navigator for i

- Right-click on IBM Tivoli Directory Server (LDAP) and select Properties.

- Click the Password button and set the LDAP administrator password and set the password.

- Click OK to set the password, then click OK again at the bottom of the properties window.
- Ensure the EIM password matches the LDAP password. In Navigator (Network) expand Enterprise Identity Mapping
- Select configuration, then right-click on the EIM domain controller and select Properties.

- Select the "System User" tab, then click the Password button and set the password the same as the LDAP administrator password.

- Click OK, then click OK again at the bottom of the properties window.
- Try to connect again via a session using Single Sign-On.
IBM Navigator for i (V7R3 and above)
NOTE: The steps are done from the IBM Navigator for i page (http://systemName:2002/Navigator or https://systemName:2003/Navigator).
Update the LDAP cn=Administrator password:
- Double click on the system to manage, then on the left menu hover over the Network icon
and click on Servers --> TCP/IP Servers:

- Right-click on 'Directory Server (LDAP)' and select Properties:

- Click the Password button and set the LDAP administrator password and set the password:

- Click OK on the password change prompt, and a second time on the properties page.
- Ensure the EIM password matches the LDAP password. On the left menu click on the Security
icon then click on 'Enterprise Identity Mapping' -> 'Configuration':

- Select configuration, then right-click on the EIM domain controller and select Properties.

- Select the "System User" tab, then click the 'Set Password' button and set the password the same as the LDAP administrator password:

- Click OK on the 'Set Password' prompt and a second time on the 'Configuration Properties' window.
- Try to connect again via a session using Single Sign-On.
The error received when trying to connect should now be resolved. If not, contact IBM Software Support for additional assistance.
Document Location
Worldwide
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Document Information
Modified date:
05 August 2022
UID
ibm16254289