IBM Support

How to resolve MSGSY1018 when connecting to the IBM i using single sign on.

Troubleshooting


Problem

When Single Sign On is configured for an IBM i and has been working, sometimes users encounter the following error message when connecting to the system:

MSGSY1018 : Kerberos credential could not be mapped for users.

Or

CWBSY1018 rc 613


Cause

This issue is normally the result of a mismatch between the LDAP and EIM cn=Administrator passwords.

Resolving The Problem

To resolve this issue, I would recommend first checking the LDAP job log on the IBM i. If you are using the default server this job is the QUSRDIR job. Check for a GLD0120 error in the job log. If you find this error continue with the following steps to resolve the issue.

Heritage IBM Navigator for i (V7R2 and below)

IBM Navigator for i (V7R3 and above)

The error received when trying to connect should now be resolved. If not, contact IBM Software Support for additional assistance.

Document Location

Worldwide


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Document Information

More support for:
IBM i

Component:
Single Sign On->Enterprise Identity Mapping

Software version:
All Version(s)

Operating system(s):
IBM i

Document number:
6254289

Modified date:
05 August 2022

UID

ibm16254289

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