Question & Answer
Question
How can I reset my BMC ADMIN password?
Cause
The BMC ADMIN password was expired, lost, or forgotten.
Answer
These instructions are for recovering the BMC ADMIN user password that is expired, lost, or forgotten. The instructions assume that the BMC is on the network.
To reset BMC ADMIN password, use one of the following methods:
1. Using the web interface:
- Enter https://<BMC_IP> into a browser
- Enter the access credentials of the BMC.
- The web interface prompts you to change the password.
2. Using Secure Socket Shell (SSL):
- Log on to the BMC by using SSH.
- The SSH prompts you to change the password.
- Follow the on-screen instructions.
3. Using local console:
- Power off the HMC.
- Power on the HMC
- Enter the petit boot menu
- Select Exit to shell
- In the shell run:
# ipmitool user list ...> to verify ADMIN user ID
#ipmitool user set password <user id> <new_password> to reset ADMIN password
#ipmitool user set password <user id> <new_password> to reset ADMIN password
4. Using in-band IPMI command: (this method can be used to reset BMC ADMIN password when it is, lost, or forgotten)
- Power on the HMC.
- Log in to the HMC as root (Contact HMC Software Support to get a temporary login for user root)
- To verify ADMIN user ID run:
# ipmitool user list
- Change the BMC ADMIN password by running the following command:
#ipmitool user set password 2 <new_password>
Where <new_password> is the new password that you want for the BMC administrator.
If ADMIN user ID is different, then substitute 2 with user ID.
Notes:
- The default password for ADMIN user is ADMIN.
- The Baseboard Management Controller (BMC) ADMIN password must be set on first use for newly manufactured systems and after a factory reset of the system. This policy change helps to enforce that the BMC is not left in a state with a well-known password.
- New password strength rules (at least 8 characters with at least one lowercase letter, one uppercase letter and one number) must be followed.
- If you are using firmware level OP825.40, or later, the root password is expired by default. You must change the default password before you can access the BMC. If you are upgrading from a previous OpenBMC firmware level, you do not have to change the password now. However, you must change the password after a factory reset.
Related Information
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Document Information
Modified date:
29 March 2022
UID
ibm16346830