IBM Support

How to reinstall Installation Manager without removing installed IBM products

Question & Answer


Question

How do you reinstall IBM Installation Manager (IM) without removing installed IBM products?

Cause

You want to reinstall Installation Manager due to following reasons:

  1. IBM Installation Manager failed during the installation or update process.

  2. Files or folders in the IBM Installation Manager installation directory were accidentally removed.

  3. The IBM Installation Manager folder contains corrupted data.

Answer


Starting in version 1.5.2 of Installation Manager, you can use the -reinstallIM option to install the same version or a later version of Installation Manager. Use this option when you have issues with the current installation of Installation Manager.

See: Install Installation Manager silently by using the installer

If you cannot use Installation Manager version 1.5.2 or above, use the method below.

Reinstall IBM Installation Manager without uninstalling the point products usually resolves most issues.

For UNIX users, the instruction below can be applied on UNIX platforms; however, you must use the UNIX paths that are listed in this table.

Windows UNIX
<code srctext="codesnippet">C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager</code> (XP and server 2003)<code srctext="codesnippet">/var/ibm/InstallationManager</code>
<code srctext="codesnippet">C:\Program Files\IBM\Installation Manager</code> (Vista, 7, and server 2008)<code srctext="codesnippet">/opt/IBM/InstallationManager</code>

  1. Make a copy of C:\Documents and Settings\All Users\Application Data\IBM\Installation Manager folder. (This folder is also known as agentDataLocation).

    To collect agentData on a different platform (for example Windows Vista or Linux) use MustGather: IBM Installation Manager troubleshooting logs technote.

    Note: agentData contains important information for IBM Installation Manager such as a list of products that have been installed, troubleshooting logs, and more. Having a copy of Installation Manager folder is good idea in case the IM install.exe fails to restore. Also, for non-admin users who previously installed IM by using userinst.exe, the agentData and the IM installed directory are located in the users' Documents and Settings folder. For example: the IM installed directory is located in C:\Documents and Settings\user1\IBM\Installation Manager .

    For IM version 1.3 or above, IM users can copy the folder by using Export Data for Problem Analysis feature: Installation Manager > Help > Export Data for Problem Analysis. If IM users have trouble copying the agentData folder, use Cannot copy Installation Manager agentData folder on Windows technote.

  2. Rename the IBM Installation Manager <installation_folder> (default location: C:\Program Files\IBM\Installation Manager) to IBM Installation Manager.bak.

    Note: This step ensures that users can reinstall the new Installation Manager (See steps 5 and 6) on the original install location.

  3. Download the latest version of IBM Installation Manager.

    Note: Find the latest version of IBM Installation Manager from the following link: IBM Installation Manager.

  4. Extract the latest version of IBM Installation Manager to a temporary folder.

  5. Go to the temporary folder that you created in step 4 and execute install.exe (Windows) or install (UNIX)

  6. Follow the instruction in the install wizard.

    Note: When the install wizard asks you for the install location, select the IBM Installation Manager <installation_folder> that was renamed in step 2.

  7. Launch IBM Installation Manager after the installation.

    Note: The IBM Installation Manager.bak and the copied <installation_folder> in steps 1-2 can be removed once Installation Manager is fully functional.

    If this does not resolve the issue, copy the agentData folder and contact IBM Support.

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Document Information

Modified date:
25 October 2021

UID

swg21290142