Question & Answer
Question
How can the Cryptographic Keys be regenerated?
NOTE: This Technote assumes customer has Cognos BI 10.2.1 (or earlier).
- If using a different version, see links at the end of this Technote.
Cause
There are several instances when the Cryptographic Keys may need to be regenerated.
Answer
According to the Administration and Security Guide:
Steps to Regenerate Cryptographic Keys
1. Stop the Cognos services.
2. On the Content Manager computer, back up the existing cryptographic keys by saving the following directories to an alternate location that is secure:
4. Delete the directories and files from point 2.
Clear all the contents of the c10_location/temp/ directory
5. In the c10_location/configuration folder, rename the existing cogstartup.xml to cogstartup.old
6. In the c10_location/configuration folder, rename backup.xml to cogstartup.xml.
7. Open Cognos Configuration, save the configuration and restart the services.
8. Repeat steps 1 - 7 on all computers that have Cognos components installed.
Note: The Dispatchers and Gateways do not have a caSerial file.
Refer to the Administration and Security Guide > Installation and Configuration Problems -> CAM-CRP-1315 Error when saving Configuration for your specific product version.
Steps to Regenerate Cryptographic Keys
1. Stop the Cognos services.
2. On the Content Manager computer, back up the existing cryptographic keys by saving the following directories to an alternate location that is secure:
- ● c10_location/configuration/csk
● c10_location/configuration/encryptkeypair
● c10_location/configuration/signkeypair
- ● c10_location/configuration/caSerial
● c10_location/configuration/cogconfig.prefs
4. Delete the directories and files from point 2.
Clear all the contents of the c10_location/temp/ directory
5. In the c10_location/configuration folder, rename the existing cogstartup.xml to cogstartup.old
6. In the c10_location/configuration folder, rename backup.xml to cogstartup.xml.
7. Open Cognos Configuration, save the configuration and restart the services.
8. Repeat steps 1 - 7 on all computers that have Cognos components installed.
Note: The Dispatchers and Gateways do not have a caSerial file.
Refer to the Administration and Security Guide > Installation and Configuration Problems -> CAM-CRP-1315 Error when saving Configuration for your specific product version.
Related Information
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Document Information
Modified date:
24 June 2019
UID
swg21383421