IBM Support

How to properly clear Microsoft's Internet Information Service (IIS) configurations to setup new configuration of IIS to support IBM Cognos

Troubleshooting


Problem

This steps should be taken prior to reconfiguring Microsoft's Internet Information Service IBM Knowledge Center article as per – Configuring IIS with Cognos Analytics (https://www.ibm.com/support/knowledgecenter/en/SSEP7J_11.0.0/com.ibm.swg.ba.cognos.inst_cr_winux.doc/t_gateway_iis.html) Or Automate the configuration of Microsoft's Internet Information Service to support IBM Cognos Analytics (http://www-01.ibm.com/support/docview.wss?uid=swg22000097)

Cause

When you attempt to overwrite your IIS configurations with new configurations there might be conflicts and cause different issues in your environment, the appropriate way would be to clear all your configurations associated with the previous IIS instance before proceeding

Resolving The Problem

Here's the guideline to follow before starting a fresh manual IIS installation or running the script
- Open IIS
- Click on Application Pools
- Select the Cognos 11 App Pool and stop it
- Expand everything
- Select the ibmcognos -> sso application and remove it
- Select the ibmcognos application and remove it
- Click on Application Pools, select the Cognos app pool, and delete it
- Close IIS

Open your file explorer
- Navigate to the Cognos gateway install directory
- Delete the following web.config files:
  • cgi-bin\web.config
  • webcontent\web.config
  • webcontent\bi\web.config

[{"Product":{"code":"SSTSF6","label":"Cognos Analytics"},"Business Unit":{"code":"BU002","label":"Business Analytics"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"11.0.8;11.0.7;11.0.6;11.0.5;11.0.4","Edition":"All Editions"}]

Document Information

Modified date:
16 August 2019

UID

swg22011418