Question & Answer
Question
How can the default port 9003 be modified if another application is already using it?
Cause
Default port 9003 the application listens on is already in use.
Answer
If the Tivoli CDP for Files or Tivoli Storage Managers FastBack for Workstations service does not start with the following error, or similar errors, in the event viewer:
EVENT ID: 6008 During socket bind operation, failed; Reason: There are no more files.
This maybe caused by the default port 9003 in use by another application. To display all the current connections and listening ports:
Click Start->Run, type cmd and click OK
Enter the netstat -a -b > out.txt
When the command finishes look through the out.txt file to determine if 9003 is in use.
To change the port that the daemon uses, the Windows registry will need to be modified:
To start the Registry Editor, select Start->Run, type regedit, and click OK
On the left hand side locate:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\FilePathsrv\
Right-click on FpPort, a DWORD value, and select Modify.
Select Decimal and enter an unused port number( for example 9005) which can easily be verified in the out.txt from the netstat command above.
After making the change , open the Task Manager and kill the filepathsrv.exe process if it is running then
go to Start->All Programs->Statup->CDPForFilesSrv or Start->All Programs->Statup->FB4WKSTNSSrv.exe to start the daemon again.
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Document Information
Modified date:
17 June 2018
UID
swg21300055