Troubleshooting
Problem
Customer would like to modify the folder that Controller uses to store its temporary/cache files.
Symptom
Customer is experiencing a problem which is being triggered by the fact that Controller is storing its cache files inside the following (default) folder: %APPDATA%\Cognos\CCR
- For examples of what symptoms the customer may be experiencing, see separate IBM Technotes #1394239, #1391066 and especially #1386354.
Cause
Controller creates and uses many cache files, inside a subfolder of the Windows system variable %APPDATA%.
By default, %APPDATA% is on the C: drive of the client device.
- Specifically, for modern Windows versions it is here: C:\Users\%USERNAME%\AppData\Roaming
This means that the default temporary/cache folder is: C:\Users\<username>\AppData\Roaming\Cognos\ccr
- For more details, see separate IBM Technote #1347422.
Resolving The Problem
Use the "CacheDir" parameter to cause the Controller local client to move the storage location of the 'cache files' (*.DSS and *.DSD) into subfolders of the CacheDir.
Example:
For example, if "CACHEDIR" is configured to be the value "D:\Controller\Cache" then these files will created/stored inside folders such as:
- D:\Controller\Cache\Windows_Username1\Cognos\CCR
- D:\Controller\Cache\Windows_Username2\Cognos\CCR
- etc.
IMPORTANT:
- Do NOT modify the location of the "Cache Dir" to either (a) a mapped network drive or (b) a network UNC path.
- Doing this will seriously affect the performance/speed of Controller, and also the stability (may create error messages).
Steps - if PC already has "Local" version of Controller client installed:
- Logon to client PC using the *same* Windows user that launches/runs Controller
- Create a folder which will be used to store the cache files (for example: D:\Controller\Cache).
IMPORTANT:
- Do not choose a network drive letter (or UNC path).
- Instead, you MUST choose a location which is on one of the client device's local hard drives.
- This does not need to be its C: drive, although it must be a local hard drive
- For example, you could choose: D:\Controller\Cache
3. Launch Windows Explorer
4. Open the folder where Controller is installed.
- For example, for Controller 10.3.1 by default this is here: C:\Program Files\ibm\IBM Cognos Controller Local Client
5. Open the file "CCR.exe.config" inside Notepad
6. Search for the entry similar to the following:
- <add key="CacheDir" value=""/>
7. Modify this entry appropriately, for example similar to the following:
- <add key="CacheDir" value="D:\Controller\Cache" />
8. Save and test
You will notice that, after launching Controller, now all the cache files are created inside the following folder: D:\Controller\Cache\<Windows_Username>\Cognos\CCR
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Steps - if PC does NOT have "Local" version of Controller client already installed:
- Logon to the client device (for example PC/laptop) as a Windows administrator
- Create a folder which will be used to store the cache files (for example: D:\Controller\Cache). IMPORTANT: Do NOT choose a network drive letter/UNC path. Instead, you MUST choose a D:\Controller\Cache\Windows_Username1\Cognos\CCRlocation.
- Inside "Add/Remove Programs" uninstall any current version of Controller
- Download the "Controller Local Client" version from the Controller application server's website (default location = http://servername/ibmcognos/controllerbin/CCRLocalClient.Msi
- Double-click on "CCRLocalClient.Msi" to launch install wizard
- Click "Next"
- Inside "Choose Setup Type" choose "Custom"
- Modify file location if desired, and choose "Next"
- Inside the "Server URLs" choose the value for WSS URL. TIP: By default, this is: http://<servername>/ibmcognos/controllerserver
- Choose the value for Help URL. TIP: By default, this is: http://<servername>/ibmcognos/ControllerHelp
- Choose the value for CACHE DIR (for example "D:\Controller\Cache")
- Click "Next" then "Install"
- Afterwards, click "Finish"
You will notice that, after launching Controller, now all the cache files are created inside the following folder: D:\Controller\Cache\<Windows_Username>\Cognos\CCR
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Document Information
Modified date:
23 June 2018
UID
swg21409414